Opened 4 years ago

Closed 4 years ago

#18353 closed defect (not a bug)

Let’s Encrypt Tor Browser 5.5.2

Reported by: HoeChiMeow Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Why is Let’s Encrypt not trusted?

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by cypherpunks

Component: - Select a componentTor Browser
Keywords: Let’s Encrypt removed
Priority: Very HighMedium
Resolution: not a bug
Status: newclosed

EFF's Let's Encrypt has its certificates signed by CAs already in the NSS cert store. It doesn't need to be another root.

If you have problems accessing a site using a certificate issued by Let's Encrypt it's probably because the site has a broken TLS setup that doesn't include the complete certificate chain. Complain to them.

Note: See TracTickets for help on using tickets.