#18450 closed defect (duplicate)

JavaScript can reveal the OS.

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This page https://www.browserleaks.com/firefox correctly shows my OS type (Linux) and my TBB version (5.5.2). Shouldn't these have been hidden?

Child Tickets

Change History (3)

comment:1 Changed 21 months ago by cypherpunks

Currently, there are several ways to detect the platform. No Javascript is required.

The font sets/whitelisted fonts are different. TBB uses the native font rendering engine - different for each platform. The UI controls are different (things like scrollbars, checkboxes, input fields). These differences can all be detected with CSS, no Javascript required.

Keyboard events are different. Resources (resource:// URIs can be be used to access various local resources) are different - that's what Browserleaks is using.

There likely is more stuff.

comment:2 Changed 21 months ago by cypherpunks

Duplicate of #8725

comment:3 Changed 21 months ago by cypherpunks

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.