Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18514 closed defect (duplicate)

Having trouble connecting to jabber.eff.org with Tor Messenger

Reported by: legind Owned by:
Priority: Medium Milestone:
Component: Archived/Tor Messenger Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I maintain jabber.eff.org. I'm having some trouble connecting to it with Tor Messenger, I keep on receiving a "The server closed the connection" message.

I definitely get a connection through with Tor, so it's not my server blocking the exit node:

legind@X1 ~ $ torsocks curl jabber.eff.org:5222
<?xml version='1.0'?><stream:stream id='' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xmlns='jabber:client'><stream:error><not-well-formed xmlns='urn:ietf:params:xml:ns:xmpp-streams'/></stream:error></stream:stream>

And the error console doesn't show anything useful for debugging. I'm able to connect to jabber.ccc.de and gchat accounts, so it's not user error.

I'm running Tor Messenger 0.1.0b5, and the server is running Prosody 0.9.10.

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by arlolra

You can enable debugging logs in Preferences > Advanced > Config Editor, set purple.debug.loglevel to 1.

Here're the relevant stanzas though. Tor Messenger sends,

<?xml version="1.0"?><stream:stream to="jabber.eff.org" xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams" version="1.0">

Prosody responds with,

<stream:stream xmlns="http://etherx.jabber.org/streams" id="" version="1.0">
</stream:stream>

However, if I telnet and send the stanza,

λ telnet jabber.eff.org 5222
Trying 173.239.79.216...
Connected to jabber.eff.org.
Escape character is '^]'.
<?xml version="1.0"?><stream:stream to="jabber.eff.org" xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams" version="1.0">
<?xml version='1.0'?><stream:stream id='' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xmlns='jabber:client'><stream:error><host-unknown xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>This server does not serve jabber.eff.org</text></stream:error></stream:stream>Connection closed by foreign host.

I wonder why we don't see a This server does not serve jabber.eff.org in the logs?

Anyways, to fix your problem, when creating your account, set the username to username and domain to eff.org, and then when you get to advanced options in the account creation wizard (3rd pane), open the xmpp options and set the server to jabber.eff.org. That seems to work for me.

comment:2 Changed 4 years ago by arlolra

This is probably a duplicate of #17461

Last edited 4 years ago by arlolra (previous) (diff)

comment:3 Changed 4 years ago by legind

Thanks arlolra, that worked for me.

comment:4 Changed 4 years ago by legind

Resolution: duplicate
Status: newclosed

comment:5 Changed 4 years ago by arlolra

Great. I'm still a little curious why I wasn't seeing that response in the debug logs though ...

Note: See TracTickets for help on using tickets.