Opened 5 years ago

Closed 5 years ago

#18633 closed defect (duplicate)

Tor service crashes on Debian sid when seccomp enabled in torrc

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.7.6
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm having issues with setting "Sandbox 1" in torrc on Debian sid. When I do, the process crashes and restarts indefinitely.

I see two suspect log entries, one from my auditd log, one from tor log.

First auditd:

type=SERVICE_START msg=audit(): pid=1 uid=0 auid= ses= msg='unit=tor@default comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'

And here is a suspect tor log entry:
(Sandbox) Caught a bad syscall attempt (syscall getsockopt)

Not entirely sure what is causing the issue. I also have apparmor enabled and enforced with the default system_tor profile, but I'm not seeing any denials being logged, so I'm assuming apparmor is not at fault.

The process restarts rapidly when this happens -- it exits and starts over and over. When I do one "ps aux | grep tor" to find the pid, then "pgrep tor" to confirm, and expect to look in /proc/(pid) to confirm sandboxing is enabled... the pid has already changed.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed

I think this is a duplicate of #18397 . Which is currently in needs-information status. If you can answer the questions there, that might help the bug get fixed. Thanks!

Note: See TracTickets for help on using tickets.