Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18667 closed defect (fixed)

Manual on website doesn't render ipv6 addresses right

Reported by: Sebastian Owned by: Sebastian
Priority: Medium Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 029-nickm-unsure
Cc: Actual Points:
Parent ID: Points: 0.5
Reviewer: Sponsor:

Description

I couldn't immediately reproduce the issue locally, will have to investigate. To see what I mean:

To specify all IPv4 and IPv6 internal and link-local networks (including 0.0.0.0/8, 169.254.0.0/16, 127.0.0.0/8, 192.168.0.0/16, 10.0.0.0/8, 172.16.0.0/12, [::]/8, /7, /10, /10, /8, and [::]/127), you can use the "private" alias instead of an address. ("private" always produces rules for IPv4 and IPv6 addresses, even when used with accept6/reject6.)

Child Tickets

Change History (7)

comment:1 Changed 3 years ago by Sebastian

Owner: set to Sebastian
Status: newassigned

comment:2 Changed 3 years ago by nickm

Keywords: 029-proposed added
Milestone: Tor: 0.2.8.x-finalTor: 0.2.???

comment:3 Changed 3 years ago by nickm

Keywords: 029-nickm-unsure added

Marking these tickets as the ones I think I need more feedback about in order to figure out if I think it should go in 0.2.9.

comment:4 Changed 3 years ago by nickm

Points: 0.5

comment:5 Changed 3 years ago by nickm

Keywords: 029-proposed removed
Milestone: Tor: 0.2.???Tor: 0.2.9.x-final

Calling these included in 0.2.9 because the (remaining) amount of work should be very small.

comment:6 Changed 3 years ago by Sebastian

Resolution: fixed
Status: assignedclosed

Finally fixed. Yuck yuck yuck.

comment:7 Changed 3 years ago by Sebastian

The fix is commit 6c84e8022ee16fcb532ebeaa0744d2dea3da379c in the webwml repo

Note: See TracTickets for help on using tickets.