Opened 21 months ago

Closed 8 months ago

#18678 closed defect (fixed)

FR: minus random number of pixels for full screen

Reported by: gt5 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-fingerprinting-resolution
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

when i maximize Tor to fullscreen, i get the message about leaving Tor at original size to prevent being tracked by my browser window size etc. when its fullscreen.

The problem is, by default the Tor window is not ideal for most pages display, so i still always need to increase the width of the window.

Would there not be a way to have a random size fullscreen mode, that just deducts a few pixels from actual fullscreen resolution,
say minus a random number between 1-50 pixels, so it gives a different browser window size each time.

not sure if i explain clear enough but i am sure you will get the picture
for example (without taking taskbars into account)
actual screen size 1920 x 1080
click Tor maximize
Tor expands to 1883 x 1062
click minimize then maximize again
and tor expands to 1907 x 1054

something like that,
this would allow users to have nearly fullscreen use, whilst always providing random browser window size to prevent tracking

Child Tickets

Change History (3)

comment:1 Changed 21 months ago by cypherpunks

Component: - Select a componentTor Browser
Owner: set to tbb-team
Type: defectenhancement

comment:2 Changed 21 months ago by bugzilla

Keywords: tbb-fingerprinting-resolution added
Type: enhancementdefect

Maximize or full screen?
What system?
It looks like different themes eat different number of pixels around the window...
On Win7 test machine there are proper 200x by 100x dimensions with 110% zoom when maximized, but 1 px stolen from width and height with 103% zoom when F11 (perhaps, it's a rounding problem).
UPDATE: What a crap? Subsequent toggling Maximize leads to 1 px stolen with 114% zoom, no rounding with no zoom, different modes on different tabs and other variations!

Last edited 21 months ago by bugzilla (previous) (diff)

comment:3 Changed 8 months ago by bugzilla

Resolution: fixed
Status: newclosed

All that weird things were fixed in 7.0a3!

Note: See TracTickets for help on using tickets.