Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1868 closed defect (duplicate)

Assertion n_to_skip + n_to_free == freelists[i].cur_length failed

Reported by: funkstar Owned by:
Priority: High Milestone: Tor: 0.2.2.x-final
Component: Core Tor/Tor Version: Tor: 0.2.2.15-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Aug 26 03:26:49.050 [Info] directory_send_command(): Downloading consensus from XXX.XXX.XXX.XXX:443 using /tor/status-vote/current/consensus/14C131+27B6B5+49015F+585769+805509+D586D1+E8A9C4+ED03BB.z
Aug 26 03:26:49.050 [Info] run_connection_housekeeping(): Expiring non-used OR connection to fd 1048 (XXX.XXX.XXX.XXX:4160) [idle 622].
Aug 26 03:26:49.050 [Info] buf_shrink_freelists(): Cleaning freelist for 4096-byte chunks: length 9, keeping 8, dropping 1.
Aug 26 03:26:49.050 [Error] buf_shrink_freelists(): Bug: buffers.c:281: buf_shrink_freelists: Assertion n_to_skip + n_to_free == freelists[i].cur_length failed; aborting.

Win7x64 Limited Account, vidalia x15 alpha (tor error)

If someone can remind me where the dumps in Windows are thrown I can fetch that also.

Child Tickets

Change History (2)

comment:1 Changed 9 years ago by nickm

Resolution: duplicate
Status: newclosed

This is a duplicate of #1125 . I'll copy-and-paste your log message there; it looks helpful. Thanks!

comment:2 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.