Opened 4 years ago

Closed 4 years ago

#18724 closed defect (duplicate)

Can't view circuit from SSL error page

Reported by: special Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I had an obvious MITM attempt on my connection to github today. As expected, I got the certificate error page and was able to view the certificate (issued by "mitmproxy").

Unfortunately, when I tried to figure out which exit I was using from the onion menu, the circuit status wasn't visible at all. I had to accept the invalid certificate in order for the page to load and to be able to view the circuit details and identify the bad exit relay. Fortunately, I didn't have any cookies for that site.

The circuit status should be visible on SSL error pages.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by gk

Resolution: fixed
Status: newclosed

Duplicate of #15897.

comment:2 Changed 4 years ago by gk

Resolution: fixed
Status: closedreopened

comment:3 Changed 4 years ago by gk

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.