Opened 3 years ago

Closed 3 years ago

#18767 closed defect (fixed)

Context menu is broken on Windows in ESR 45 based Tor Browser

Reported by: gk Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: ff45-esr, tbb-6.0a5, TorBrowserTeam201604
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The context menu is essentially unusable on Windows with a ESR45 based Tor Browser. The problem is visible in the browser console:

ReferenceError: Intl is not defined LoginManagerContextMenu.jsm:20:3

We are still compiling Tor Browser for Windows with ICU disabled but there are more and more features in Firefox that rely on it (even if there are still a bunch of them with fallback mode due to Firefox on Android not shipping ICU yet).

Child Tickets

Change History (4)

comment:1 Changed 3 years ago by gk

I guess the right thing to do is fix the ICU compilation for Windows once and for all which means #13419.

Version 0, edited 3 years ago by gk (next)

comment:2 Changed 3 years ago by gk

Keywords: TorBrowserTeam201604 added

comment:3 Changed 3 years ago by mcs

Cc: brade mcs added

Kathy and I hunted for a few minutes to find other JS files that use "Intl." We found the following:

services/common/hawkrequest.js
toolkit/components/passwordmgr/content/passwordManager.js
toolkit/components/passwordmgr/LoginManagerContextMenu.jsm
toolkit/components/narrate/NarrateControls.jsm
toolkit/mozapps/downloads/DownloadUtils.jsm

I am sure we could avoid these uses if necessary by doing some hacky things, but fixing #13419 seems like the best option.

comment:4 Changed 3 years ago by gk

Resolution: fixed
Status: newclosed

Fixed by #13419.

Note: See TracTickets for help on using tickets.