Opened 4 years ago

Last modified 14 months ago

#18778 needs_information defect

TBB hangs with 100% CPU when cancelling ftp download or http channel Listener OnDataAvailable contract violation

Reported by: bugzilla Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-crash
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Child Tickets

Change History (13)

comment:1 Changed 4 years ago by gk

Status: newneeds_information

Seems you put the wrong like for the steps to reproduce? If not could you elaborate on what the issue is and how the link related to it?

comment:2 Changed 4 years ago by cypherpunks

Hehe, I knew I remembered that message from somewhere.

gk, look at the browser console while opening that URL. You should see the message in the title.

comment:3 Changed 4 years ago by gk

Status: needs_informationassigned

FWIW this only happens if you cancel the download and is probably related to our hack showing the external resources warning dialog.

comment:4 in reply to:  2 Changed 4 years ago by bugzilla

Replying to cypherpunks:
Thanks, cpunks. Even with STR Georg thinks bugzilla is wrong again...

gk: Is everything else with the webpage correct for you?

comment:5 Changed 3 years ago by bugzilla

Keywords: tbb-crash added
Summary: http channel Listener OnDataAvailable contract violationTBB hangs with 100% CPU when cancelling ftp download or http channel Listener OnDataAvailable contract violation

comment:6 Changed 3 years ago by bugzilla

When cancelling Download in pdf.js (6.5a2)

NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIExternalHelperAppService.doContent] PdfStreamConverter.jsm:306:0

comment:7 Changed 14 months ago by traumschule

Resolution: fixed
Status: assignedclosed

Can't reproduce a crash with 8.0.2, log for "Safest":

Content Security Policy: Couldn’t process unknown directive ‘report-to’ (unknown)
Loading failed for the <script> with source “https://gcc.gnu.org/bugzilla/data/assets/7aea391f77d255cdd754e18ddbf1133b.js?1507639999”.  attachment.cgi:15
Loading failed for the <script> with source “https://gcc.gnu.org/bugzilla/data/assets/2e6e421b95bc76c273c65f113df06e10.js?1507639999”.  attachment.cgi:65
Content Security Policy: The page’s settings blocked the loading of a resource at https://gcc.gnu.org/bugzilla/data/assets/7aea391f77d255cdd754e18ddbf1133b.js?1507639999 (“script-src”). (unknown)
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: 
    <!--
        YAHOO.namespace('bugzi....

and with js enabled

Content Security Policy: The page’s settings blocked the loading of a resource at https://gcc.gnu.org/bugzilla/data/assets/2e6e421b95bc76c273c65f113df06e10.js?1507639999 (“script-src”). (unknown)
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: onsubmit attribute on FORM element. attachment.cgi
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: 
      if (history && history.replaceSta.... attachment.cgi:108
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: onclick attribute on A element. attachment.cgi
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: onclick attribute on BUTTON element. attachment.cgi
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: 
              YAHOO.util.Dom.removeClas.... attachment.cgi:408
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: 
      if (history && history.replaceSta.... attachment.cgi:453
Loading failed for the <script> with source “https://gcc.gnu.org/bugzilla/data/assets/7aea391f77d255cdd754e18ddbf1133b.js?1507639999”.  attachment.cgi:15
Loading failed for the <script> with source “https://gcc.gnu.org/bugzilla/data/assets/2e6e421b95bc76c273c65f113df06e10.js?1507639999”.  attachment.cgi:65

For "Standard" nothing is logged.

Version 0, edited 14 months ago by traumschule (next)

comment:8 Changed 14 months ago by traumschule

Resolution: fixed
Status: closedreopened

WORKSFORME fits better.

comment:9 Changed 14 months ago by traumschule

Resolution: worksforme
Status: reopenedclosed

comment:10 Changed 14 months ago by Unicode

Resolution: worksforme
Status: closedreopened

You didn't test all the cases, so, please, don't close Tor Browser's tickets. Thanks.
(BTW, Ctrl+S bypasses warning dialog entirely.)

comment:11 Changed 14 months ago by traumschule

Status: reopenedneeds_information

Which cases? Please list the steps and i will add them to the description.

comment:12 Changed 14 months ago by Unicode

ftp, http, pdf... You seem to be a newbie here, so don't hurry...

comment:13 Changed 14 months ago by traumschule

This ticket is missing steps to reproduce. To raise chances it get's fixed bring it in better shape for developers to look at.

Note: See TracTickets for help on using tickets.