Opened 9 years ago

Closed 9 years ago

#1879 closed defect (duplicate)

torbutton prevents a user from exporting their personal certificates from firefox

Reported by: d-b Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Torbutton Version: Torbutton: 1.4.0
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

torbutton prevents a user from exporting their personal certificates from firefox.

Feature: export personal certificates
As A user I want to
Export my personal certificates I use to sign into websites
So that I can back them up and not loose access to the accounts and therefore profit!!!

Background:
Scenario: With tor button enabled in firefox.
Given I have a personal certificate for foo.com

Scenario: With tor button enabled in firefox.
When I select backup my certificate for foo.com to a file called 'foo.com-saved'
Then I should see my certificate saved in foo.com-saved

Scenario: With tor button enabled in firefox.
And I have a personal certificate for bar.com
When I select backup all from the certificate manager into the file 'export-certs.saved'
Then I should see my certificates saved in 'export-certs.saved'

--> what happens is actually that it doesn't work (torbutton blocks this).
You have to disable the torbutton extension to be able to export certificates.

Child Tickets

Change History (1)

comment:1 Changed 9 years ago by arma

Resolution: duplicate
Status: newclosed

duplicate of #975

Note: See TracTickets for help on using tickets.