Opened 4 years ago

Closed 4 years ago

#18791 closed defect (fixed)

Fix for #13252 does not compile on ESR 45

Reported by: gk Owned by: mcs
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Critical Keywords: ff45-esr, tbb-6.0a5, TorBrowserTeam201604R
Cc: Actual Points:
Parent ID: #15197 Points:
Reviewer: Sponsor:

Description

I tried to test our hardened builds setup with the latest branch Arthur posted (15197+11) and the build failed badly pretty early:

Reticulating splines...
Traceback (most recent call last):
  File "./config.status", line 1061, in <module>
    config_status(**args)
  File "/home/debian/build/tor-browser/python/mozbuild/mozbuild/config_status.py", line 175, in config_status
    definitions = list(definitions)
  File "/home/debian/build/tor-browser/python/mozbuild/mozbuild/frontend/emitter.py", line 177, in emit
    objs = list(self.emit_from_context(out))
  File "/home/debian/build/tor-browser/python/mozbuild/mozbuild/frontend/emitter.py", line 608, in emit_from_context
    for obj in self._process_sources(context, passthru):
  File "/home/debian/build/tor-browser/python/mozbuild/mozbuild/frontend/emitter.py", line 797, in _process_sources
    'exist: \'%s\'' % (symbol, full_path), context)
mozbuild.frontend.reader.SandboxValidationError: 
==============================
ERROR PROCESSING MOZBUILD FILE
==============================

The error occurred while processing the following file or one of the files it includes:

    /home/debian/build/tor-browser/xpcom/io/moz.build

The error occurred when validating the result of the execution. The reported error is:

    File listed in UNIFIED_SOURCES does not exist: '/home/debian/build/tor-browser/xpcom/io/TorFileUtils.cpp'


*** Fix above errors and then restart with\
               "make -f client.mk build"
make: *** [configure] Error 1

Not sure if that's a rebase issue or something different yet.

Child Tickets

Attachments (1)

0001-fixup-Bug-13252-Do-not-store-data-in-the-app-bundle.patch (7.3 KB) - added by mcs 4 years ago.
fixup patch that restores TorFileUtils.h and TorFileUtils.cpp

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by gk

Summary: Fix for #13252 does not comiple on ESR 45Fix for #13252 does not compile on ESR 45

comment:2 Changed 4 years ago by mcs

It looks like a rebase issue. The files xpcom/io/TorFileUtils.cpp and xpcom/io/TorFileUtils.h are missing (not included in ac1a02c6653c1fd1dbb313eb02e3eb89b00cb1bb).

comment:3 Changed 4 years ago by mcs

Just in case Arthur does not already have rebased versions of the two missing files, I will attach a fixup patch that includes them. Compared to the ESR38-based version of xpcom/io/TorFileUtils.cpp, Kathy and I switched to .forget() for returning addref'd values and we also fixed a warning caused by redeclaration of rv.

Changed 4 years ago by mcs

fixup patch that restores TorFileUtils.h and TorFileUtils.cpp

comment:4 Changed 4 years ago by mcs

Keywords: TorBrowserTeam201604R added
Status: newneeds_review

comment:5 Changed 4 years ago by gk

Looks good to me.

comment:6 Changed 4 years ago by arthuredelstein

Thanks for finding this and sorry for accidentally leaving out those files. I used the fixup patch and added it to
https://github.com/arthuredelstein/tor-browser/commits/15197+11
Hash: f08e3270b9cb65844585279bcc1eaaeb80f0ba35

comment:7 in reply to:  6 Changed 4 years ago by mcs

Replying to arthuredelstein:

Thanks for finding this and sorry for accidentally leaving out those files. I used the fixup patch and added it to
https://github.com/arthuredelstein/tor-browser/commits/15197+11
Hash: f08e3270b9cb65844585279bcc1eaaeb80f0ba35

I don't see this commit. Maybe you need to push it to github?

comment:8 Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Seems to be there now. Closing this one, too.

Note: See TracTickets for help on using tickets.