Opened 3 years ago

Closed 3 years ago

#18844 closed defect (fixed)

browser hangs when clicking in bookmarks window

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Steps to reproduce:

1) Bookmarks -> Show All Bookmarks
2) Under the "All Bookmarks" heading in the list on the left side of the window, click on "Bookmarks Toolbar" or "Bookmarks Menu"

Expected result:
Seeing the contents of those subfolders in a timely fashion.

Actual result:
Entire browser stops accepting keyboard and mouse input for ~30 seconds. Browser may remain sluggish afterwards until relaunched.

The other items in the list do not exhibit this problem, just those two subfolders.

I have observed this on SubgraphOS (Debian, using xpra as an X proxy) but someone in the #subgraph channel reproduced it without xpra too.

Child Tickets

Change History (2)

comment:1 Changed 3 years ago by cypherpunks

I can't reproduce this connecting directly to the local X.

Does it happen in Firefox/Ice* with your setup?

comment:2 Changed 3 years ago by cypherpunks

Resolution: fixed
Status: newclosed

OP here. Just tried to repro this (again on Subgraph w/xpra) after updating to the latest TBB 5.5.5 and I could not.

This was definitely not just a one-time problem though, several subgraph developers said they reproduced it before I opened this ticket. Maybe the new firefox fixed it somehow, or maybe something else changed. In any case I guess this can be closed.

Note: See TracTickets for help on using tickets.