Opened 3 years ago

Closed 2 years ago

#18846 closed defect (worksforme)

Tor never shut up even the user set Log level ERROR.

Reported by: ikurua22 Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

---
tor's default file: changed last line(Log notice...) to:
Log err file /dev/null

tor's default file(lib/tor/torrc):
Log err file /dev/null
---
(no "Log" section in each files except these 2 lines)

Even I done these changes, and restart Tor, it still writes
many lines to syslog.

Why TOR never shut up?

syslog
[notice] Opening Socks listener...

WHY, Tor write "[notice]" log to syslog?

Child Tickets

Change History (8)

comment:1 Changed 3 years ago by ikurua22

+ reproduceable at least 5+ systems.
+ using your repository for install/update.

comment:2 Changed 3 years ago by teor

Resolution: not a bug
Status: newclosed
Type: taskdefect

This is a feature, not a bug.

Tor writes its initial log messages to stdout, while caching a copy of them.
It then parses its config, and flushes the cache to the configured log.

Writing the initial output to stdout is a feature, in case tor crashes on startup.
We can't wait until we've parsed the config to write log messages.

Please start your tor as:
tor > /dev/null
to achieve the results you want.

comment:3 Changed 3 years ago by cypherpunks

The manual also mentions this and offers the --quiet and --hush options.

comment:4 Changed 3 years ago by ikurua22

Hi all, if you're still reading this, would you tell me how to do
"tor > /dev/null" ?

I always use "service tor stop" or "service tor start" to use tor, no idea how to achieve this.

comment:5 Changed 3 years ago by arma

The original bug reporter said "syslog".

It sounds to me that he has some Tor package that has a pre-configured line to log to syslog. Adding a second log line, to log at level err, won't do anything about the first one.

So the first question is: which package exactly?

comment:6 Changed 3 years ago by ikurua22

Resolution: not a bug
Status: closedreopened

Oh hi arma.

Yeah, I'm talking about "syslog". I'm not sure what "stdout" means; if it is about
"screen message", then no I didn't see any stdout message.

Reopening this issue; if you *strongly* believe I'm wrong, just tell me what to do first before closing.
I'm listening.

which package exactly?

Debian. Apt update from your project.

---

cat /var/log/syslog|grep tor

(toooooooooooooooooo many tor logs. grepping only first lines)
NSA_Agent_X tor[1234]: Apr 99 11:22:33.456 [notice] Tor v0.2.7.6 (git-605ae665009853bd) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.1k and Zlib 1.2.8.
NSA_Agent_X tor[1234]: Apr 99 11:22:33.456 [notice] Tor can't help you if you use it wrong! Learn how to be safe at httpS!!www.torproject.org/download/download#warning
NSA_Agent_X tor[1234]: Apr 99 11:22:33.456 [notice] Read configuration file "/usr/share/tor/tor-service-defaults-torrc".
NSA_Agent_X tor[1234]: Apr 99 11:22:33.456 [notice] Read configuration file "/etc/tor/torrc".

cat /usr/share/tor/tor-service-defaults-torrc|grep Log

Log err file /dev/null
(I added it because I want to disable any kinds of logging.)

cat /etc/tor/torrc|grep Log

##Log notice syslog
Log err file /dev/null
(1st line; comment out by "#"(I used it for debugging a few months ago). 2nd line is active of course... I think.)

cat /etc/apt/sources.list|grep tor

deb http!!!!!deb.torproject.org/torproject.org jessie main
deb-src http!!!!!eb.torproject.org/torproject.org jessie main
---

Any ideas?
(!) "!!!" ... because this trac told me I'm spamming your trac. WTF

Version 0, edited 3 years ago by ikurua22 (next)

comment:7 Changed 3 years ago by nickm

Milestone: Tor: unspecified

comment:8 Changed 2 years ago by nickm

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.