Opened 3 years ago

Closed 3 years ago

#18874 closed defect (fixed)

PayPal donation form defaults back to $23

Reported by: mo Owned by: Sebastian
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://www.torproject.org/donate/donate.html.en

Enter any other amount, then remove the focus again, eg. by clicking on the website background: $23 will become the default again, and indeed when you click the Donate button Paypal uses $23 instead of the custom amount entered.

Child Tickets

Change History (6)

comment:1 Changed 3 years ago by mo

"Looks like a bug in the html-or-javascript-or-css in the page.

The bug only triggers when you first get to the page. (You can reproduce
it with a new Tor Browser tab since Tor Browser will make it like you
have never been to the page before.)

If you load https://www.torproject.org/donate/donate.html.en and then
click on "other" and type "5" and then click donate, it will indeed
revert back to 23 right when you go to Paypal.

If you instead click on other, type 5, then click elsewhere on the page
so it reverts to 23, then click back on the 5, it will stay a 5."

comment:2 Changed 3 years ago by cypherpunks

After looking at the source it seems to be a bug in the Javascript. At line 127 the value of the amount id is checked. This id is empty initially, so the default amount is set to 23 and the $23 button is activated. It doesn't check the custom amount until the function is called a second time because the amount is then set and the second if statement is checked instead.

comment:4 Changed 3 years ago by zizou

Status: newneeds_review

comment:5 Changed 3 years ago by Sebastian

Merged, thank you!

comment:6 Changed 3 years ago by Sebastian

Resolution: fixed
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.