Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#1888 closed defect (user disappeared)

Some small problems with my relay

Reported by: BahTheSheep Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.1.26
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I restart my computer I and I look at my Tor log I get the message that my relay is up and running, but not that my ORport and Directory port are reachable. Does that mean that they are not reachable?

Child Tickets

Change History (16)

comment:1 Changed 9 years ago by arma

What exactly are the log messages that you get?

comment:2 Changed 9 years ago by BahTheSheep

Exactly what I'm saying. The first time I set up my relay it said ORport reachable and same for Directory port and now nothing. In advanced it would say excellent, but since basic doesn't say its reachable advanced doesn't say anything at all about it.

Sorry it took so long been busy.

comment:3 Changed 9 years ago by arma

I can't answer your question without seeing all the log messages you're seeing -- exactly the ones you're seeing. Don't paraphrase them or leave some out because you figure they're not worth mentioning. I'm trying to figure out what your problem is, and I haven't figured it out yet, so I sure can't suggest any solutions yet.

comment:4 Changed 9 years ago by BahTheSheep

Do you want the log with debugging or just what I've got now?

comment:5 Changed 9 years ago by BahTheSheep

I just noticed that my ip is set to 0.0.0.0 might that be the problem? It had set itself before, but how can I set it manually?

comment:6 Changed 9 years ago by Sebastian

No, there is no problem. It can happen with Vidalia.

comment:7 Changed 9 years ago by BahTheSheep

sep 02 00:50:40.968 [Notice] Tor v0.2.1.26. This is experimental software. Do not rely on it for strong anonymity. (Running on Windows XP Service Pack 3 [workstation] {terminal services, single user})
sep 02 00:50:41.078 [Notice] Initialized libevent version 1.4.12-stable using method win32. Good.
sep 02 00:50:41.078 [Notice] Opening OR listener on 0.0.0.0:9001
sep 02 00:50:41.078 [Notice] Opening Directory listener on 0.0.0.0:9030
sep 02 00:50:41.078 [Notice] Opening Socks listener on 127.0.0.1:9050
sep 02 00:50:41.078 [Notice] Opening Control listener on 127.0.0.1:9051
sep 02 00:50:41.078 [Notice] Parsing GEOIP file.
sep 02 00:51:04.765 [Notice] Performing bandwidth self-test...done.

comment:8 Changed 9 years ago by BahTheSheep

This is what I get

comment:9 Changed 9 years ago by BahTheSheep

I have restarted vidalia a couple a times and at a certain point I get this:
sep 02 12:32:29.265 [Notice] Tor v0.2.1.26. This is experimental software. Do not rely on it for strong anonymity. (Running on Windows XP Service Pack 3 [workstation] {terminal services, single user})
sep 02 12:32:29.265 [Notice] Initialized libevent version 1.4.12-stable using method win32. Good.
sep 02 12:32:29.265 [Notice] Opening OR listener on 0.0.0.0:9001
sep 02 12:32:29.265 [Notice] Opening Directory listener on 0.0.0.0:9030
sep 02 12:32:29.375 [Notice] Opening Socks listener on 127.0.0.1:9050
sep 02 12:32:29.375 [Notice] Opening Control listener on 127.0.0.1:9051
sep 02 12:32:29.375 [Notice] Parsing GEOIP file.
sep 02 12:33:18.203 [Notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
sep 02 12:33:18.203 [Warning] router_orport_found_reachable(): Bug: ORPort found reachable, but I have no routerinfo yet. Failing to inform controller of success.
sep 02 12:33:22.609 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
sep 02 12:33:26.390 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
sep 02 12:33:26.390 [Notice] Bootstrapped 100%: Done.
sep 02 12:34:18.281 [Notice] Your DNS provider gave an answer for "b7inw6br3oivj.org", which is not supposed to exist. Apparently they are hijacking DNS failures. Trying to correct for this. We've noticed 1 possibly bad address so far.
sep 02 12:34:39.281 [Notice] Guessed our IP address as 80.56.78.10 (source: 208.53.142.44).
sep 02 12:35:58.187 [Notice] Self-testing indicates your DirPort is reachable from the outside. Excellent.
sep 02 12:37:55.312 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'torserversNet4'. Retrying on a new circuit.
sep 02 12:37:55.328 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'torserversNet4'. Retrying on a new circuit.
sep 02 12:37:56.312 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'torserversNet4'. Retrying on a new circuit.
sep 02 12:38:04.187 [Notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
sep 02 12:39:20.406 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:80. Giving up. (waiting for circuit)
sep 02 12:39:20.406 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
sep 02 12:39:21.406 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:80. Giving up. (waiting for circuit)
sep 02 12:39:52.453 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
sep 02 12:46:06.953 [Notice] Performing bandwidth self-test...done.

comment:10 Changed 9 years ago by BahTheSheep

SORRY FOR THE CAPS BUT I'M REALLY FRUSTRATED AND ANGRY NOW. HAD TO REBOOT AGAIN AND AFTER THE REBOOT VIDALIA ASKED FOR A PASSWORD NOT A PROBLEM HAD THAT BEFORE. I SOLVED THAT BY REBOOTING (DON'T KNOW IF THAT'S THE PROPER WAY), BUT AFTER THAT NO RELAY AT ALL OR ANYTHING. I GO TO SETTINGS AND PRESS TEST AND I GET MY FAMOUS: "No UPnP-enabled devices found" AAAAAAAAAAAAAAAAAAAAAAARGH!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

WHAT THE FUCK IS GOING WITH TOR. WHY THE HELL IS IT SO HARD TO GET IT WORKING IN WINDOWS XP. MIGHT AS WELL JUST DE-INSTALL IT DOESN'T WORK IN WINDOWS APPARENTLY OR DOESN'T WANT TO.

FIX IT WILL YA PLEASE. ITS KILLING ME. AND AGAIN SORRY FOR THE CAPS, BUT I'M JUST PISSED OFF

comment:11 Changed 9 years ago by arma

My guess is your relay is working fine.

What is its nickname? I can check it in the network status from this end.

comment:12 Changed 9 years ago by nickm

Hello? Are you still there?

comment:13 Changed 9 years ago by nickm

Milestone: Tor: unspecified

comment:14 Changed 8 years ago by nickm

Resolution: user disappeared
Status: newclosed

No contact in 8 months; closing as "user disappeared".

comment:15 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:16 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.