Opened 14 years ago

Last modified 14 years ago

#189 closed defect (Not a bug)

tor didn't find libevent in /usr/lib

Reported by: Martin Owned by:
Priority: High Milestone:
Component: Tor-Other Version: unspeficied
Severity: Keywords:
Cc: Martin Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

is it possible to build tor-0.1.1.7.alpha
with libevent installed in /usr/lib ???

ll /usr/lib/libevent-1.1a.so.1*
lrwxrwxrwx 1 root root 22 13. Sep 19:42 /usr/lib/libevent-1.1a.so.1 -> libevent-1.1a.so.1.0.2
-rwxr-xr-x 1 root root 91314 13. Sep 18:40 /usr/lib/libevent-1.1a.so.1.0.2

rpmbuild --rebuild tor-0.1.1.7.alpha-tor.0.fc1.src.rpm

this ist error message i get:

checking for a normal libevent... no
checking for libevent in /usr/local/lib... no
configure: error:
Tor requires libevent to build. You can download the latest
version of libevent from http://monkey.org/~provos/libevent/
Fehler: Bad exit status from /var/tmp/rpm-tmp.41415 (%build)

[Automatically added by flyspray2trac: Operating System: Linux]

Child Tickets

Attachments (1)

config.log (11.5 KB) - added by Martin 14 years ago.
config.log

Download all attachments as: .zip

Change History (8)

comment:1 Changed 14 years ago by nickm

Hm. It seems to work for us. Do you get the same error when you try to compile Tor from source?

comment:2 Changed 14 years ago by Martin

same error if i build it from source.

comment:3 Changed 14 years ago by nickm

Could you please attach a config.log ?
Is your /usr/lib in your LDPATH ?
Also, what distribution are you using?

Changed 14 years ago by Martin

Attachment: config.log added

config.log

comment:4 Changed 14 years ago by Martin

Im using Fedora Core4 and /usr/lib is in the LDPATH
ldconfig -v |grep libevent

libevent-1.1a.so.1 -> libevent-1.1a.so.1.0.2

export LDFLAGS="-L/usr/lib"
./configure

gives me the same result.
config.log is attached.

comment:5 Changed 13 years ago by nickm

Hm. It still works for me on fedora core 4. Did you install the libevent-devel package?

comment:6 Changed 13 years ago by Martin

Ok, tor-0.1.1.10-alpha.tar.gz compiles now on FC4,
after installing libevent-devel-1.1a-2.fc4.i386.rpm

Bugreport could be closed.

thanks Martin

comment:7 Changed 13 years ago by nickm

flyspray2trac: bug closed.
Okay; it seems that libevent-devel was missing. We need to remember this the next time someone asks.

Note: See TracTickets for help on using tickets.