Opened 3 years ago

Closed 3 years ago

#18900 closed defect (fixed)

TB 6.0a5: updater doesn't work on Linux (cannot find libraries)

Reported by: mcs Owned by: mcs
Priority: Immediate Milestone:
Component: Applications/Tor Browser Version:
Severity: Blocker Keywords: ff45-esr, tbb-6.0a5, TorBrowserTeam201604R
Cc: gk, mcs, brade, boklm, tbb-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When testing the 6.0a5 updater using our own Linux64 build, the updater fails to run because it cannot locate Mozilla shared libraries:

error while loading shared libraries: libmozsqlite3.so: cannot open shared object file: No such file or directory

Code in toolkit/xre/nsUpdateDriver.cpp is supposed to add the Browser directory to LD_LIBRARY_PATH. We will need to see why that is not happening.

Child Tickets

Change History (8)

comment:1 Changed 3 years ago by gk

Status: newneeds_information

Thanks for finding this one. I guess this is a blocker for the 6.0a5 release? This basically means updating from 6.0a4 is working but one from 6.0a5 to 6.5a1 would break, right?

comment:2 in reply to:  1 Changed 3 years ago by mcs

Replying to gk:

Thanks for finding this one. I guess this is a blocker for the 6.0a5 release? This basically means updating from 6.0a4 is working but one from 6.0a5 to 6.5a1 would break, right?

Correct: the update to version.next will fail. And it does seem like a blocker. We are working on understanding this bug so we can create a fix for it.
In hindsight, Kathy and I should have tested this sooner :(

comment:3 Changed 3 years ago by gk

Priority: Very HighImmediate
Severity: NormalBlocker
Status: needs_informationassigned

No worries, we gonna ship the alpha one day later then

comment:4 Changed 3 years ago by mcs

This bug is caused by a Mozilla change that I was worried about when I first saw it:
https://bugzilla.mozilla.org/show_bug.cgi?id=1159090#c4

Kathy and I are making a Linux build of our own right now to verify that backing out the Bugzilla 1159090 change fixes this ticket. Later we can work on a better fix that Mozilla will accept.

comment:5 Changed 3 years ago by boklm

Cc: boklm tbb-team added

comment:6 Changed 3 years ago by mcs

Keywords: ff45-esr tbb-6.0a5 TorBrowserTeam201604 added

comment:7 Changed 3 years ago by mcs

Keywords: TorBrowserTeam201604R added; TorBrowserTeam201604 removed
Status: assignedneeds_review

comment:8 Changed 3 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks, fixed with commit 82cfa7c8786c1ad1421666365bd71f3594861328 on tor-browser-45.1.0esr-6.0-1.

Note: See TracTickets for help on using tickets.