Opened 4 years ago

Closed 3 years ago

#18961 closed defect (fixed)

tor_bug_occurred_(): Bug: ../src/or/dnsserv.c:298

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Minor Keywords: dnsserv, regression
Cc: Actual Points:
Parent ID: Points: 1
Reviewer: Sponsor:

Description

I found those lines in my logs ; the system is debian unstable 32 bit

[...] [warn] tor_bug_occurred_(): Bug: ../src/or/dnsserv.c:298: evdns_get_orig_address: This line should not have been reached. (Future instances of this warning will be silenced.) (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug: Line unexpectedly reached at evdns_get_orig_address at ../src/or/dnsserv.c:298. Stack trace: (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(log_backtrace+0x52) [0x80dd2802] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(tor_bug_occurred_+0xb6) [0x80dea186] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(dnsserv_resolved+0x1f2) [0x80dbc302] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(connection_ap_handshake_socks_resolved+0xc4) [0x80d84db4] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(+0x53058) [0x80cf8058] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(circuit_receive_relay_cell+0x2d2) [0x80cf85c2] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(command_process_cell+0x179) [0x80d65899] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(channel_queue_cell+0x1e6) [0x80d432b6] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(channel_tls_handle_cell+0x15a) [0x80d4891a] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(+0xe5d7c) [0x80d8ad7c] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(+0xd40f5) [0x80d790f5] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(+0xdd209) [0x80d82209] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(+0x30589) [0x80cd5589] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/lib/i386-linux-gnu/libevent-2.0.so.5(event_base_loop+0x79d) [0xb725810d] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(do_main_loop+0x29f) [0x80cd662f] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(tor_main+0x18a5) [0x80cd9c05] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(main+0x35) [0x80cd1f25] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /lib/i386-linux-gnu/i686/cmov/libc.so.6(__libc_start_main+0xf7) [0xb6d76527] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)
[...] [warn] Bug:     /usr/bin/tor(+0x2cf81) [0x80cd1f81] (on Tor 0.2.9.0-alpha-dev 8340becd39920ef6)

Child Tickets

Change History (13)

comment:1 Changed 4 years ago by nickm

Keywords: 029-proposed dnsserv added
Severity: NormalMinor

Proposing that we look at this for 0.2.9; also proposing that we assign it a "minor" priority: this is not actually causing a problem; it's just hitting a "tor_fragile_assert()" line.

comment:2 Changed 4 years ago by nickm

Keywords: 029-nickm-says-yes added

comment:3 Changed 4 years ago by nickm

Points: 1

comment:4 Changed 4 years ago by nickm

Keywords: 029-proposed removed
Milestone: Tor: 0.2.9.x-final

Calling these "yes" because they are bugfixes.

comment:5 Changed 4 years ago by isabela

Keywords: isaremoved added
Milestone: Tor: 0.2.9.x-finalTor: 0.2.???

comment:6 Changed 4 years ago by nickm

Keywords: regression nickwants029 added

comment:7 Changed 4 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:8 Changed 4 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:9 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:10 Changed 3 years ago by nickm

Keywords: isaremoved removed

comment:11 Changed 3 years ago by nickm

Keywords: 029-nickm-says-yes removed

comment:12 Changed 3 years ago by nickm

Keywords: nickwants029 removed

comment:13 Changed 3 years ago by nickm

Resolution: fixed
Status: newclosed

I am pretty sure this is a duplicate of #19869, fixed in 0.2.9.5-alpha

Note: See TracTickets for help on using tickets.