Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18983 closed task (not a bug)

TBB + Flagfox - doesn't work

Reported by: ikurua22 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: daveg.extensionfeedback@…, davemgarrett Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

tbb: doesn't show country icon
firefox(old): show country code

Child Tickets

Change History (7)

comment:1 Changed 3 years ago by davemgarrett

Hello, Flagfox developer here. (please replace the CC to the support email address with a CC for this new account)

I'm a little confused as to why this issue was posted here. Flagfox has not ever been able to show a flag when running under Tor, when things are properly configured. The addon is technically compatible with TBB, and some other functions do work, but Flagfox is fundamentally incapable of showing location information through Tor, as the entire purpose of Tor is to hide such information. Flagfox specifically asks Firefox/TBB for proxy info for a site before doing a DNS lookup (hitting the cache) to fetch the IP address to look up in an optimized and compressed version of Maxmind's IP location database. (there isn't another simple way to grab the IP used for a given resource) If Firefox/TBB is configured to only use its proxy, in this case Tor, and not do local DNS lookups, Flagfox will not kick off a new one. This is to avoid leaking DNS lookups and weakening the protection a proxy/Tor gives. (the detection code isn't perfect, but neither is the DNS backend Mozilla has that doesn't do this automatically) If there is some way to proxy a DNS request safely through Tor, I don't know a simple way to do that on my end. Do note that I am limited by what Mozilla APIs are available here.

Here's an old stickied FAQ on this topic from the Flagfox support forum:
https://flagfox.net/forum/viewtopic.php?f=3&t=20

comment:2 Changed 3 years ago by davemgarrett

Cc: davemgarrett added

comment:3 Changed 3 years ago by ikurua22

Resolution: not a bug
Status: newclosed

I don't know about Firefox extension development, but how about adding

===
[X] Use HTTP API to get DNS information (e.g., can't use local DNS)
API URL: [ http;getinfo.mydomain.com/forflagfox.php?q=%% ]
===

Developer user are encouraged to download "forflagfox.php" and place it to
their own server. And, TBB will access to "HTTP API" to gather information(like FQDN->IP).

Closing this ticket because it seems this is not TBB related. Sorry guys.
Maybe I'll visit Flagfox forum soon, if it is NOT blocking Tor, of course.

comment:4 Changed 3 years ago by cypherpunks

Summary: TBB + Flafox - doesn't workTBB + Flagfox - doesn't work

@davemgarrett
"No soup for you! It looks like you have been flagged as a spammer."

@ikurua22

if it is NOT blocking Tor, of course.

Bad news, it's blocking register lol

Adding him to https://trac.torproject.org/projects/tor/wiki/org/doc/ListOfServicesBlockingTor .

comment:5 Changed 3 years ago by ikurua22

Ty for trying it out; I simply don't go there then.
Many websites are eager to collect individual information nowadays.
Using Tor blocking system such as this and Cloudflare will just let Tor users away from
their website. It's okay, you don't like "Anonymous' contribution" then.
Hope dave implement HTTP API(use my own API), if he's reading this.

Since Flagfox's discussion is not related to TBB, let's forget about this

comment:6 Changed 3 years ago by davemgarrett

Adding an API to every server is just not practical. What might be, is an idea I got in a discussion with someone at Mozilla very recently: Google apparently has a DNS server with an HTTPS API. I'd certainly not want to use it over a regular proxy, but over Tor this might be an option to look into (which Google fortunately does not block).

As to the forum issue... ugh. I'll contact the admin and see if we can get that fixed. There's only two of us doing this as a hobby, and we've had to deal with an stupid amount of spam and abuse, so I guess a Tor exit node got blocked at some point. I'm contactable via email if need be (as adding me to the CC here shows). As to anonymous contribution, it's a support forum, so without an email at sign up it's useless for most people as there's no way to discuss anything. It'd be nice if there was a simple way to solve this issue, but there isn't; sorry for Tor getting caught in the spamwar crossfire, yet again. :/

comment:7 in reply to:  4 Changed 3 years ago by davemgarrett

Replying to cypherpunks:

@davemgarrett
"No soup for you! It looks like you have been flagged as a spammer."

@ikurua22

if it is NOT blocking Tor, of course.

Bad news, it's blocking register lol

Adding him to https://trac.torproject.org/projects/tor/wiki/org/doc/ListOfServicesBlockingTor .

This should hopefully be fixed. Please verify, when you get a chance.

Note: See TracTickets for help on using tickets.