Opened 3 years ago

Closed 3 years ago

#18984 closed enhancement (fixed)

List 64-bit Linux Tor Browser first on download pages?

Reported by: arma Owned by: Sebastian
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On https://www.torproject.org/download/download-easy and https://www.torproject.org/download/download we list the 32-bit Tor Browser first, and the 64-bit Tor Browser second.

Assumption 1: they don't work if you fetch the wrong one. specifically, I think the 32-bit one does not work on 64-bit systems. I just checked this again and it seems to be true.

Assumption 2 (Karsten or Sebastian can learn whether this is true, e.g. from the same analysis as on #18768): The 64-bit bit one is more used, since a lot of people are 64-bit people nowadays.

If both of these assumptions turn out to hold, I think we should list the 64-bit one first.

Child Tickets

Change History (2)

comment:1 Changed 3 years ago by sojka

I can confirm that Assumption 1 is somewhat true: the user needs some 32bit libraries on his 64bit system to have Tor browser work and people often don't have it because majority of all software is installed through package managers which automatically fetch the right package for the users architecture.

By the way, the closed-source Google Chrome browser (as opposed to the opensource Chromium) ends support for 32 bit by Chrome 47. https://threatpost.com/google-ends-chrome-support-on-32-bit-linux-releases-chrome-47/115526/

comment:2 Changed 3 years ago by Sebastian

Resolution: fixed
Status: newclosed

[x]

Note: See TracTickets for help on using tickets.