Opened 3 years ago

Closed 6 weeks ago

#18991 closed enhancement (not a bug)

Use HIBERNATION_STATUS in header panel

Reported by: atagar Owned by: atagar
Priority: Very Low Milestone:
Component: Core Tor/Nyx Version:
Severity: Minor Keywords: header
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Nyx's header panel polls the control port for hibernation information. Tor 0.2.9.x adds a new HIBERNATION_STATUS event we can listen to instead to cut down on the GETINFO queries we make.

This is a very small change to our load on the control port (one GETINFO request every five seconds), so not really a high priority. If somebody wants to do this then great, but I'll probably wait until tor versions prior to 0.2.9.x are deprecated to avoid the headache of 'if version x to this, if y do that'.

Child Tickets

Change History (1)

comment:1 Changed 6 weeks ago by atagar

Resolution: not a bug
Status: newclosed

On reflection there's actually nothing to be done with this. The graph panel polls accounting data to display hibernation status, but it presents accounting stats as well (which HIVERNATION_STATUS understandably does not provide).

Note: See TracTickets for help on using tickets.