Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19010 closed defect (duplicate)

Rendezvous points are too strict about RENDEZVOUS1 payload length

Reported by: arma Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 029-proposed
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor: SponsorR-can

Description

In rend_mid_rendezvous() we do

  if (request_len != REND_COOKIE_LEN+DH_KEY_LEN+DIGEST_LEN) {
    log_fn(LOG_PROTOCOL_WARN, LD_PROTOCOL,
         "Rejecting RENDEZVOUS1 cell with bad length (%d) on circuit %u.",
         (int)request_len, (unsigned)circ->p_circ_id);
    reason = END_CIRC_REASON_TORPROTOCOL;
    goto err;
  }

which is sad, because it locks us in to a particular RENDEZVOUS2 payload format. In the future, we want to be able to use other payload formats. So we should stop rejecting RENDEZVOUS1 cells with other payload lengths.

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by special

Resolution: duplicate
Status: newclosed

Duplicate of #18998

comment:2 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:3 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.