Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19017 closed defect (duplicate)

Extrainfo digest did not match digest256 from routerdesc

Reported by: toralf Owned by: nickm
Priority: Medium Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version: Tor: 0.2.8.2-alpha
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points: small
Reviewer: Sponsor:

Description

I do get still tons of those messages althought running up-to-date version of tor.

Child Tickets

Attachments (3)

notice.log (320.6 KB) - added by toralf 3 years ago.
cached-descriptors.new.xz (447.6 KB) - added by toralf 3 years ago.
cached-extrainfo.new.xz (446.4 KB) - added by toralf 3 years ago.

Download all attachments as: .zip

Change History (10)

Changed 3 years ago by toralf

Attachment: notice.log added

Changed 3 years ago by toralf

Attachment: cached-descriptors.new.xz added

Changed 3 years ago by toralf

Attachment: cached-extrainfo.new.xz added

comment:1 Changed 3 years ago by toralf

The other files are bigger than 3 MB, you can download them from https://www.zwiebeltoralf.de/pub/

comment:2 Changed 3 years ago by teor

Keywords: must-fix-before-028-rc added
Milestone: Tor: 0.2.8.x-final
Points: small

We will never get useful feedback on an RC unless we fix these copious warning messages.

comment:3 Changed 3 years ago by nickm

Probably a duplicate of #17150, where apparently the loglevel wasn't as fixed as we had thought.

comment:4 Changed 3 years ago by nickm

Owner: set to nickm
Status: newaccepted

Analyzing the log and the source: these seem to be extrainfos that we are downloading at startup. This is indeed 0.2.8.2-alpha-dev. For whatever reason, we are hitting this message mostly:

"Extrainfo digest did not match digest256 from routerdesc"

and occasionally this one:

"Extrainfo signing key cert didn't match routerinfo"

but never this one:

"Neither digest256 or digest matched digest from routerdesc";

Nearly every id that appears, appears once. Only a few seem to appear twice.

In every case, the ri id matches the ei id.

Ah, I think I see the problem. Hang on.

comment:5 Changed 3 years ago by nickm

Actual Points: 0.2

comment:6 Changed 3 years ago by nickm

Actual Points: 0.2
Keywords: must-fix-before-028-rc removed
Resolution: duplicate
Status: acceptedclosed

Closing this as a duplicate of #17150, moving that one back.

comment:7 Changed 3 years ago by nickm

(#17150 now has a fix for review.)

Note: See TracTickets for help on using tickets.