Opened 4 years ago

Closed 4 years ago

#19065 closed defect (fixed)

Tor Browser icon not visible anymore in upper left corner on Linux since 05/13

Reported by: gk Owned by: gk
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff45-esr, TorBrowserTeam201605R, tbb-regression, GeorgKoppen201605, tbb-6.0-must
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The nightly build from May 09 is the last one still showing the Tor Browser icon in the upper left corner of browser windows/dialogs. The nightly from May 13 is the first one that just shows a placeholder icon on Linux.

Child Tickets

Change History (7)

comment:1 Changed 4 years ago by gk

Keywords: tbb-regression added

comment:2 Changed 4 years ago by gk

Keywords: ff45-esr added
Owner: changed from tbb-team to gk
Status: newassigned

comment:3 Changed 4 years ago by gk

Keywords: GeorgKoppen201605 added

comment:4 Changed 4 years ago by gk

Keywords: tbb-6.0-must added

comment:5 Changed 4 years ago by gk

Keywords: TorBrowserTeam201605R added; TorBrowserTeam201605 removed
Status: assignedneeds_review

It seems we have been a bit overzealous in our fix for #18915 by deleting the whole chrome folder. bug_19065 (https://gitweb.torproject.org/user/gk/tor-browser-bundle.git/commit/?h=bug_19065) in my tor-browser-bundle repo is correcting this mistake.

comment:6 in reply to:  5 Changed 4 years ago by mcs

Cc: brade mcs added

Replying to gk:

It seems we have been a bit overzealous in our fix for #18915 by deleting the whole chrome folder. bug_19065 (https://gitweb.torproject.org/user/gk/tor-browser-bundle.git/commit/?h=bug_19065) in my tor-browser-bundle repo is correcting this mistake.

r=brade, r=mcs
Your fix looks fine. It looks like Mac and Windows do not have such a directory.

And I am sorry for suggesting that you add 'rm -rf chrome'. Maybe in the long run we should unzip into a temporary directory to avoid this kind of collision.

comment:7 Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

No worries. Applied this master (091cb50929055718277fcede5f61c61504ab8b87) and hardened-builds (48055f68ba9954c402760b91a5096f98d6720665).

Note: See TracTickets for help on using tickets.