Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1921 closed defect (fixed)

Cell statistics warn when being enabled while Tor is running

Reported by: karsten Owned by: karsten
Priority: Low Milestone: Tor: 0.2.2.x-final
Component: Core Tor/Tor Version: Tor: 0.2.2.15-alpha
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Moritz Bartl reports that enabling CellStatistics and sending Tor a HUP signal results in:

[warn] connection_or_flush_from_first_active_circuit(): Bug: Cannot
determine insertion time of cell.

It's not a bug that a cell was put in the queue when we didn't collect cell statistics and was removed from the queue when we did.

Child Tickets

Change History (6)

comment:1 Changed 9 years ago by Sebastian

Milestone: Tor: 0.2.2.x-final
Status: newneeds_review

Add a fix for this in branch bug1921 in my repository.

comment:2 Changed 9 years ago by arma

Looks good to me.

Might be useful to get Karsten to check it out too, but if he doesn't, please merge.

comment:3 Changed 9 years ago by karsten

Sebastian's fix looks good. Thanks!

But the ChangeLog should say it's a bugfix on 0.2.2.15-alpha, because enabling stats while Tor is running (which leads to this false log message) is only possible since then.

comment:4 Changed 9 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Merged with suggested changelog change. Thanks!

comment:5 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:6 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.