Opened 3 years ago

Last modified 3 years ago

#19214 new defect

After updating to TB 6.0.0, displayed search plugins reset

Reported by: ironical Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-6.0-issues, tbb-usability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser 6.0.0, Windows

After opting for the update to 6.0.0 through the built-in update mechanism, my browser plugins were reset to the default set of plugins and my default search preference was also changed.

The strange this is that my "old" search plugins are still there in the proper folder (\Browser\browser\searchplugins), and if I add a new search plugin from in-browser, it saves it to this same location, but the "old" ones are ignored.

Any ideas? Thanks if you can help bringing them back!

Child Tickets

Change History (4)

comment:1 Changed 3 years ago by cypherpunks

You can try this temporary work-around (as always, make a backup first):

  1. Close Tor Browser.
  2. In Tor Browser's profile: rm search.json*
  3. Restart Tor Browser.

The file should be regenerated from the stuff in "seaarchplugins/".

If you had custom order/keywords, then those should be in "search-metadata.json". You might need to restore that, or manually re-add them, not sure.

The next update will again break your search plugins.

comment:2 Changed 3 years ago by gk

Keywords: tbb-6.0-issues tbb-usability added; tor browser search plugin 6.0.0 removed

comment:3 Changed 3 years ago by ironical

@cypherpunks - Thank you for the tips! I just tried what you said (and more) on 6.0.1 and it was unsuccessful. I deleted the search.json* files, at times together with search-metadata.json. But no matter where I copy my group of .xml search plugins, TB doesn't register it.

What's more, I can no longer track where TB stores the search plugins. When I add a totally new search plugin, there is no new .xml that can be detected, so now I'm confused even about the location. This wasn't true with 6.0.0.

In short, previously used search plugins all became obsolete. What could be done to bring them back to life?

comment:4 Changed 3 years ago by ironical

Lo and behold, after the nth restart, it recognized my search plugins.
It may also has to do with the fact that I copied the .xml's in every "searchplugins" directory I found.

Note: See TracTickets for help on using tickets.