Opened 3 years ago

Closed 3 years ago

#19257 closed defect (duplicate)

Tor Browser on Windows is using msvcr120.dll and crashing

Reported by: gk Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-crash, tbb-6.0-issues
Cc: mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

WE have the following crash report on our blog (https://blog.torproject.org/blog/tor-browser-60-released#comment-183775):

Problem signature:
Problem Event Name: APPCRASH
Application Name: firefox.exe
Application Version: 45.1.1.0
Application Timestamp: 00000000
Fault Module Name: MSVCR120.dll
Fault Module Version: 12.0.21005.1
Fault Module Timestamp: 524f7ce6
Exception Code: c0000005
Exception Offset: 00013b0b
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 4d1c
Additional Information 2: 4d1ccb1f086e8f68af5ebd400b9240a6
Additional Information 3: a773
Additional Information 4: a7738b1c9bfdec77d1b26715e67e5bda

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

This is actually weird as we should not use msvcr120.dll at all.

Child Tickets

Change History (6)

comment:1 Changed 3 years ago by gk

Keywords: tbb-crash added

comment:2 Changed 3 years ago by cypherpunks

https://www.reddit.com/r/TOR/comments/4m79fi/tor_stopped_responding/

FIX - i uninstalled trusteer endpoint protection ( wouldnt let me disable ) and Tor works fine :D

comment:3 Changed 3 years ago by mcs

Cc: mcs added

comment:4 Changed 3 years ago by gk

Keywords: tbb-6.0-issues added

comment:5 Changed 3 years ago by bugzilla

Can be closed as a duplicate of #8337.
Because it is about C:\Program Files (x86)\Trusteer\Rapport\bin\MSVCR120.dll which was mentioned in https://blog.torproject.org/blog/tor-browser-601-released#comment-186489.

But what about to investigate the difference in usage of MSVCR100.dll and MSVCR120.dll (as Mozilla has MSVS 2013 as the minimal supported version)?

comment:6 Changed 3 years ago by gk

Resolution: duplicate
Status: newclosed

I just checked our firefox.exe and it is correctly dependent on msvcr100.dll being around. Thus, this is just a duplicate of #8337.

Note: See TracTickets for help on using tickets.