Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19269 closed defect (fixed)

Tor Browser icon doesn't appear in Applications folder or Dock

Reported by: cypherpunks Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Trivial Keywords: TorBrowserTeam201607R, tbb-usability
Cc: mcs, brade, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I installed Tor Browser 6.0 for OS X in the Applications folder using a user account with Administrator privileges. It installed successfully and the program icon appears both in the Applications folder and in the Dock when the program is running. If I log in to the computer using a user account with Standard privileges, the program icon doesn't appear either in Applications or in the Dock. I'm using OS X 10.10.5 (Build 14F1509).

Child Tickets

Change History (8)

comment:1 Changed 3 years ago by cypherpunks

It should be said that Tor Browser 6.0 installs successfully, and the the program does appear in the Applications folder and the Dock, it's just a cosmetic problem that only affects non-Administrator user accounts.

comment:2 Changed 3 years ago by mcs

Cc: mcs brade added

When I tried to reproduce this, in addition to the icon not being shown I saw a "corrupted application" error when I tried to open Tor Browser from the Standard account. To fix the problem, I did this (in Terminal) from the Administrator account:

chmod -R o+rx /Applications/TorBrowser.app

Maybe we need to change the permissions within the .dmg.

comment:3 Changed 3 years ago by gk

Cc: gk added

Is that a new thing coming with 6.0? I wonder if we are doing something wrong when recreating the .dmg after signing although I am using the same tools/scripts.

comment:4 in reply to:  3 Changed 3 years ago by mcs

Replying to gk:

Is that a new thing coming with 6.0? I wonder if we are doing something wrong when recreating the .dmg after signing although I am using the same tools/scripts.

I do not think this is new with TB 6.0. Looking at some other dmg-based packages (e.g., the Xcode installer), they use a mode of 755 for directories and 644 for files. Since we no longer store user data within the bundle on Mac OS, I think it is safe for us to do the same thing now.

Is gitian/build-helpers/ddmg.sh the correct script to modify? It already uses find to exec chmod to change the mode on each item that goes into the dmg.

comment:5 Changed 3 years ago by gk

I think so.

comment:6 Changed 3 years ago by mcs

Keywords: TorBrowserTeam201607R added
Status: newneeds_review

comment:7 Changed 3 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Applied to master and maint-6.0 (commit 3c39bce72160b9dbbf1196deea613ad8e2116eaa and a444e50be76078eead724908f9154d9217ec3f91).

comment:8 Changed 3 years ago by gk

Keywords: tbb-usability added
Note: See TracTickets for help on using tickets.