Opened 3 years ago

Closed 15 months ago

#19328 closed defect (duplicate)

Try not to log from inside functions called from inside log functions

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: recursion, logging, tor-relay, technical-debt, refactor, stack-overflow, blob, callgraph, tor-dos
Cc: Actual Points:
Parent ID: #16764 Points: 2
Reviewer: Sponsor: SponsorS-can

Description

Our logging code is technically recursive now. Logging asks what the time is and tries to format it. Formatting the time can fail. Failures can log.

Child Tickets

Change History (11)

comment:1 Changed 3 years ago by nickm

Points: 2

comment:2 Changed 3 years ago by nickm

I think maybe the best we can do here is to say that some assertion failures or error logs are deep, and have them use a slightly different log mechanism without possibility of recursion.

comment:3 Changed 3 years ago by isabela

Keywords: isaremoved added
Milestone: Tor: 0.2.9.x-finalTor: 0.2.???

comment:4 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:5 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:6 Changed 2 years ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:7 Changed 2 years ago by nickm

Keywords: isaremoved removed

comment:8 Changed 2 years ago by nickm

Keywords: recursion logging tor-relay dos technical-debt refactor stack-overflow blob callgraph added

comment:9 Changed 19 months ago by dgoulet

Keywords: tor-dos added; dos removed

Rename keyword "dos" to "tor-dos"

comment:10 Changed 15 months ago by teor

nickm, have we solve this ticket already?

comment:11 Changed 15 months ago by nickm

Milestone: Tor: unspecifiedTor: 0.3.5.x-final
Resolution: duplicate
Status: newclosed

Yes! Closing this ticket as a duplicate of #26427.

Note: See TracTickets for help on using tickets.