Opened 3 years ago

Last modified 10 months ago

#19335 new defect

Tor circuit display shows example circuit instead of real

Reported by: axdoomer Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-circuit-display, tbb-6.0-issues
Cc: arthuredelstein, Mofasa, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I upgraded to the new version 6.0.0 and now I got this when I display the tor circuit:

http://i.imgur.com/UjqcbQA.png

It says the site is "example.com" and all the nodes are "Example A", "Example B" and "Example C". When I change my tor circuit, I'm not sure if it's working.

I'm on Windows 7 Ultimate 64-bits.

Child Tickets

Attachments (1)

tb_8.0.3_circuit-view.png (153.6 KB) - added by traumschule 10 months ago.
Seeing this with 8.0.3 right now, so far no idea how to reproduce it in a fresh one.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 3 years ago by axdoomer

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:2 Changed 3 years ago by gk

Cc: arthuredelstein added
Keywords: tbb-circuit-display tbb-6.0-issues added
Status: newneeds_information

Interesting. Is this reproducible? Is this on every website happening?

comment:3 Changed 3 years ago by arthuredelstein

This probably indicates an error in torbutton. Could you open the browser console (Tools > Web Developer > Browser console) and paste any errors you see after starting Tor Browser and opening a single website? Thanks.

comment:4 Changed 3 years ago by Mofasa

Have same problem. (Tor 6.0.1 (based on Mozilla Firefox 45.2.0))

getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService] torbutton.js:1619:0
getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057

comment:5 Changed 3 years ago by axdoomer

This is what I get in the browser console:

getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
TypeError: popup is null

toolbar_button.js:308:5

getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
TypeError: popup is null

toolbar_button.js:308:5

getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
getFirstPartyURI failed for chrome://devtools/content/webconsole/webconsole.xul: 0x80070057
getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
getFirstPartyURI failed for chrome://devtools/content/webconsole/webconsole.xul: 0x80070057
getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
no element found data::1:1
1465433159600 addons.productaddons ERROR Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https." nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145" data: no] Log.jsm:751:0
1465433159600 Toolkit.GMP ERROR GMPInstallManager.simpleCheckAndInstall Could not check for addons: [Exception... "SSL is required and URI scheme is not https." nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145" data: no] Stack trace: checkCert()@resource://gre/modules/CertUtils.jsm:145 < downloadXML/</success()@resource://gre/modules/addons/ProductAddonChecker.jsm:113 Log.jsm:751:0
Tor NOTICE: I learned some more directory information, but not enough to build a circuit: We have no recent usable consensus.
getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057

Last edited 3 years ago by axdoomer (previous) (diff)

comment:6 in reply to:  4 ; Changed 3 years ago by gk

Replying to Mofasa:

Have same problem. (Tor 6.0.1 (based on Mozilla Firefox 45.2.0))

getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService] torbutton.js:1619:0
getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057

Is that reproducible? If so, how? Do you use a vanilla Tor Browser in the default setup?

comment:7 in reply to:  6 Changed 3 years ago by Mofasa

Replying to gk:

Replying to Mofasa:

Have same problem. (Tor 6.0.1 (based on Mozilla Firefox 45.2.0))

getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057
NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService] torbutton.js:1619:0
getFirstPartyURI failed for chrome://browser/content/browser.xul: 0x80070057

Is that reproducible? If so, how? Do you use a vanilla Tor Browser in the default setup?

Sorry for late reply but I don't use Tor often.
I'm using the Tor browser package with few modifications. Have a few addons like NoScript, Adblock and Better Privacy. Other then that it's using the default settings... as far as I can remember. Still have it and it's always "on". That is that I can't do anything about it so all I have to do to reproduce it is to open the browser again. Will test a few settings now and see if I can find anything useful.

Edit
Just disabled all addons except for TorLauncher and TorButton and that did not help.

Last edited 3 years ago by Mofasa (previous) (diff)

comment:8 Changed 3 years ago by gk

Cc: Mofasa gk added

Hi Mofasa! Is that still an issue for you?

comment:9 Changed 23 months ago by cypherpunks

Summary: Tor circuit not displayedTor circuit display shows example circuit instead of real

Changed 10 months ago by traumschule

Attachment: tb_8.0.3_circuit-view.png added

Seeing this with 8.0.3 right now, so far no idea how to reproduce it in a fresh one.

comment:10 Changed 10 months ago by gk

Status: needs_informationnew
Note: See TracTickets for help on using tickets.