Opened 3 years ago

Closed 2 years ago

#19336 closed defect (fixed)

Make text stand out in about:tbupdate

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, TorBrowserTeam201608R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

All text seems very plain and normal it doesn't stand out as an update at all and I can see someone simply closing it or moving to another page without realising an update has taken place.

One step would be to bold the text:
"Tor Browser has been updated."
"Changelog:"

Secondly may not be related, but on tor browser startup the url bar is empty and it doesn't say whether it is about:tor or about:tbupdate why is this?

Child Tickets

Change History (3)

comment:1 in reply to:  description Changed 2 years ago by mcs

Replying to cypherpunks:

Secondly may not be related, but on tor browser startup the url bar is empty and it doesn't say whether it is about:tor or about:tbupdate why is this?

It is common practice to hide the URL for built-in pages. This makes it easier for users to enter a different URL and also hides ugly names like about:tbupdate from users.

comment:2 Changed 2 years ago by mcs

Keywords: tbb-usability TorBrowserTeam201608R added
Status: newneeds_review

We went ahead and made some text bold as was suggested. We also fixed #19835. Please review:

https://gitweb.torproject.org/user/brade/tor-browser.git/commit/?h=bug19336-01&id=219b21731bec577b8797a8914612f0ae9e55d1ad

comment:3 Changed 2 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good to me. I applied the patch to tor-browser-45.3.0esr-6.5-1 (commit 219b21731bec577b8797a8914612f0ae9e55d1ad). We can backport that to the stable branch if all works out as intended.

Note: See TracTickets for help on using tickets.