#19411 closed defect (fixed)

Update icon shows up even if partial updates are failing

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201606R, tbb-6.0-issues
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While investigating #19410 I realized that the green icon on the hambuger menu is showing up as well if the partial update is failing. I confirmed that clicking on it restarts the browser but still there is no update (obviously) to 6.0.1. This is pretty confusing. This was tested on OS X.

Child Tickets

Change History (3)

comment:1 Changed 21 months ago by mcs

Keywords: TorBrowserTeam201606R tbb-6.0-issues added
Status: newneeds_review

Here is a fix:
https://gitweb.torproject.org/user/brade/tor-browser.git/commit/?h=bug19411-01&id=8d80221e8cfdc85e1b6c7692542181621b2eb4f1

Assuming this works for us, we should file a bug against Firefox as well (since it very likely has the same bug).

comment:2 Changed 20 months ago by gk

Looks good to me. I applied this to tor-browser-45.2.0esr-6.5-1 and tor-browser-45.2.0esr-6.0-1 (it looked simple enough): 8d80221e8cfdc85e1b6c7692542181621b2eb4f1 and 15792fd075f46d2150a566bd546ec41b427f3588.

mcs/brade: Could you file a ticket in Mozilla's bug tracker and attach your patch there? This is the only thing left to be done before closing this ticket.

Last edited 20 months ago by gk (previous) (diff)

comment:3 Changed 20 months ago by mcs

Resolution: fixed
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.