Opened 3 years ago

Closed 3 years ago

#19421 closed defect (fixed)

test-network-all target does not work with out-of-tree builds

Reported by: cypherpunks Owned by: cypherpunks
Priority: Medium Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: easy
Cc: teor Actual Points:
Parent ID: Points:
Reviewer: Sponsor: SponsorS-can

Description

This is caused by assuming the test-driver script is the build directory. The Automake variable LOG_DRIVER contains the correct path.

Child Tickets

Attachments (1)

0001-Fix-test-network-all-target-in-out-of-tree-builds.patch (2.1 KB) - added by cypherpunks 3 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 3 years ago by cypherpunks

Owner: set to cypherpunks
Status: newassigned

The LOG_DRIVER variable cannot be used because it was added in Automake 1.12 and Tor still supports Automake 1.11. Instead we should just use the default value of LOG_DRIVER directly.

comment:2 Changed 3 years ago by cypherpunks

Status: assignedneeds_review

The attached patch is ready for review but it'll need to be rebased when #18933 gets merged because both set of patches change the same lines.

comment:3 Changed 3 years ago by nickm

Cc: teor added
Milestone: Tor: 0.2.9.x-final
Sponsor: SponsorS-can

comment:4 Changed 3 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

lgtm; merged!

Note: See TracTickets for help on using tickets.