Opened 3 years ago

Closed 3 years ago

#19438 closed defect (not a bug)

Addons do not work randomly

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I sometimes install other addons beside the defaults like uBlock.

I noticed that sometimes, it is recurring not one off, but when Tor Browser is restarted or 'New Identity' is clicked addons do not work. For example, keep an icon of the addon on the Menu or Bookmarks tab - to reproduce try restarting the browser or closing the browser and reopening or even try new identity button (doesn't always happen but you will run it to it sooner or later).

I know addons other than the default ones aren't supported but there may be another issue with Tor Browser as to why sometimes addons aren't working (haven't tested the default addons but they may also stop working) which should be looked into.

Using the 6.0.1 Browser on Linux 64 platform

Child Tickets

Change History (6)

comment:1 Changed 3 years ago by cypherpunks

What do you mean exactly by "addons do not work."? Be a bit more precise, what error messages, or what doesn't work, et cetera.

I'm also running TBB 6.0.1 on Linux 64-bit w/ uBlock Origin installed but never experienced any issues.

comment:2 in reply to:  1 Changed 3 years ago by cypherpunks

Replying to cypherpunks:

What do you mean exactly by "addons do not work."? Be a bit more precise, what error messages, or what doesn't work, et cetera.

I'm also running TBB 6.0.1 on Linux 64-bit w/ uBlock Origin installed but never experienced any issues.

I just reproduced this issue and from a basic overview of what I see

Addons do not work = addon icon does not show up at all and addon does not seem to function when this happens (for uBlock it is shown as installed but when you click preferences you cannot click the logger or dashboard through the addon page. Then restart so the icon comes back and now you click the dashboard and logger).

Put the uBlock icon in your bookmark toolbar so you see it every time you load Tor Browser. It is usually there but when it disappears and that is when you know the addon is not properly working

Last edited 3 years ago by cypherpunks (previous) (diff)

comment:3 Changed 3 years ago by gorhill

you cannot click the logger or dashboard through the addon page

I've just experienced this -- this was first time I saw such behavior.

This occurred while the Tor browser took an unusually long to initialize and launch. There is a time-out in uBO at launch time after which it will give up trying to start. It's my best guess as to what might be happening.

Can you confirm that the issue occurs only when it takes long before the Tor browser is launched? (Something like more than 30 seconds) If so, the fix would probably simply to make uBO wait longer on various browser internals to be ready at launch time before giving up.

Last edited 3 years ago by gorhill (previous) (diff)

comment:4 in reply to:  3 Changed 3 years ago by cypherpunks

Replying to gorhill:

you cannot click the logger or dashboard through the addon page

I've just experienced this -- this was first time I saw such behavior.

This occurred while the Tor browser took an unusually long to initialize and launch. There is a time-out in uBO at launch time after which it will give up trying to start. It's my best guess as to what might be happening.

Can you confirm that the issue occurs only when it takes long before the Tor browser is launched? (Something like more than 30 seconds) If so, the fix would probably simply to make uBO wait longer on various browser internals to be ready at launch time before giving up.

From my limited testing, what you said seems right - it happens almost always when Tor browser takes long to load (sometimes around 30 seconds-2 minutes maybe more). When it loads quick (within 20 seconds), I am not able to reproduce yet.

Last edited 3 years ago by cypherpunks (previous) (diff)

comment:5 Changed 3 years ago by gorhill

I just released 1.7.5rc7 with what is hopefully a fix for the issue here. It's also available in the dev channel of the extension on AMO.

comment:6 Changed 3 years ago by gk

Resolution: not a bug
Status: newclosed

If that is not related to uBlock please reopen.

Note: See TracTickets for help on using tickets.