Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#1945 closed defect (fixed)

TBB for Linux cannot find default Xauthority file

Reported by: temp_error_finder Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb linux
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

As mentioned on the blog:

The following is something I observed. Linux Tor bundle works, apart from a notice when starting, on PCLinuxOS 2010.07 openbox (live CD), Mandriva 2010.0 (HD installed) and Parsix 3.6r0(Live and Install). It returns an error when started from Kubuntu 10.04(live CD) that uses KDE 3.5.11.

This could be related to the KDE because this KDE version is a continuation of KDE 3.5.10, in a project known as Trinity desktop. I have heard that there was a memory leak in X on Ubuntu 10.04, I am not sure if this was in a release or beta of Ubuntu.

The following is shown

------------
No protocol specified
vidalia: cannot connect to X server :0.0
------------

The following is the X -version

--------------------------
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-25-server i686 Ubuntu
Current Operating System: Linux ubuntu 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/kubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --
Build Date: 23 April 2010 05:11:50PM
xorg-server 2:1.7.6-2ubuntu7 (Bryce Harrington )
Current version of pixman: 0.16.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.


Child Tickets

Attachments (1)

strace.dump (113 bytes) - added by temp_error_finder 9 years ago.
strace dump

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by temp_error_finder

Attachment: strace.dump added

strace dump

comment:1 Changed 9 years ago by phobos

Component: - Select a componentTor bundles/installation
Owner: set to erinn

comment:2 Changed 9 years ago by erinn

Status: newaccepted

This is an X problem, not a Tor Browser Bundle problem. Is there any chance it's being launched from within a chroot? Does 'echo $DISPLAY' say :0.0?

comment:3 Changed 9 years ago by erinn

Resolution: user disappeared
Status: acceptedclosed

Since this isn't a TBB problem and the guy hasn't responded, I'm closing this.

temp_error_finder, if you reappear, please let me know if you have more info or reason to believe this is a TBB bug. Thanks!

comment:4 Changed 9 years ago by dmiceman

Resolution: user disappeared
Status: closedreopened

Same here. There is something wrong with $HOME variable handling inside vidalia (or Qt). Steps to reproduce:

  1. cd to directory where bundle is unpacked
  2. HOME=pwd LD_LIBRARY_PATH=pwd/Lib ./App/vidalia

results with:

No protocol specified
vidalia: cannot connect to X server :0

Definitely, $DISPLAY is set properly. If vidalia is run without enforced HOME (LD_LIBRARY_PATH=pwd/Lib ./App/vidalia), than it run properly.

Up to date arch linux, bundle version 1.0.15.

comment:5 Changed 9 years ago by dmiceman

And… Solved :-) Probably, there is a need to add a string into the start-tor-browser script:

cp ~/.Xauthority .

Most linux distros does not allow unauthorized connections to the X server.

comment:6 Changed 8 years ago by rransom

Version: Tor: 0.1.0.10

TBB works for me. (My X server is started by GDM, and my XAUTHORITY environment variable is set to an absolute path.)

We have had another report recently on tor-assistants that TBB for Linux does not work when X is started by XDM, but does work when X is started by startxfce4. This problem is most likely caused by a bug in how XDM and KDM initialize the XAUTHORITY environment variable. We should be able to work around that bug, but not until we know what those display managers set XAUTHORITY to.

comment:7 Changed 8 years ago by rransom

Summary: Linux Tor Bundle 1.0.10; Vidalia can not connect to XTBB for Linux cannot find default Xauthority file

XDM does not set the XAUTHORITY environment variable.

comment:8 Changed 8 years ago by rransom

The fix for this is to put:

test "z$XAUTHORITY" != "z" || export XAUTHORITY="$HOME/.Xauthority"

in start-tor-browser.sh somewhere before HOME is changed.

comment:9 Changed 8 years ago by erinn

My fix is slightly different from rransom's (see here: https://gitweb.torproject.org/torbrowser.git/blobdiff/84e1f32a0dace1ef960fc1b328b4bcad61dbc41f..c66ed4c55395fe9f5e9e173a02854051c9bad6a3:/src/RelativeLink/RelativeLink.sh), but I think it works the same. It's in the latest 1.1.6 linux bundles. Can someone else test and confirm?

comment:10 Changed 8 years ago by erinn

Resolution: fixed
Status: reopenedclosed

This is fixed. Closing.

comment:11 Changed 8 years ago by karsten

Keywords: tbb linux added
Milestone: Tor Browser Bundle for Linux
Note: See TracTickets for help on using tickets.