Opened 3 years ago

Closed 3 years ago

#19464 closed defect (fixed)

Remove confusing warning when using +HSPOST

Reported by: twim Owned by:
Priority: Medium Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs control
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When one is using +HSPOST for descriptor upload tor drops a warning that corresponding service is (obviously) not found.

Ger 51 -1:242:47.000 [warn] Service [scrubbed] not found after descriptor upload

It's kind of confusing since this warning was added when all the onion services were "internal". This is not true anymore.

I've downgraded debug level for this message from warn to info. Maybe this message should be removed at all?

Child Tickets

Attachments (2)

19464-warn-to-info.tor.patch (927 bytes) - added by twim 3 years ago.
19464-remove-message.patch (1.4 KB) - added by twim 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by twim

comment:1 Changed 3 years ago by dgoulet

Keywords: tor-hs control 029-proposed added; tor warning hspost removed
Status: newmerge_ready

ACK for me. Putting it in merge_ready because it's a trivial one liner.

HSPOST is used to detect malicious HSDir and it's a pretty annoying message to get thousands of time at warn level.

comment:2 Changed 3 years ago by nickm

Keywords: 029-proposed removed
Milestone: Tor: 0.2.9.x-final
Status: merge_readyneeds_revision

Hm. Is there a reason to have this message at all?

It is phrased as though there's a problem, but there isn't.

IMO either the message should say something more neutral, or it should be a warning in the case when it's actually a problem, or we should just remove it.

Also, needs a changes file.

comment:3 Changed 3 years ago by twim

Maybe this message should be removed at all?

Hm. Is there a reason to have this message at all?

Yeap, now I'm sure that it's absolutely useless since there are no problems to be reported.

Also, needs a changes file.

How to make that?

comment:4 in reply to:  3 ; Changed 3 years ago by cypherpunks

Replying to twim:

Also, needs a changes file.

How to make that?

See the How we log changes section in doc/HACKING/CodingStandards.md.

comment:5 in reply to:  4 Changed 3 years ago by twim

Replying to cypherpunks:

Replying to twim:

Also, needs a changes file.

How to make that?

See the How we log changes section in doc/HACKING/CodingStandards.md.

Great, thanks!
Made one. But 'bugfix does not say 'bugfix on X.Y.Z'. Is it OK?

Changed 3 years ago by twim

Attachment: 19464-remove-message.patch added

comment:6 Changed 3 years ago by nickm

sure; I can fix that.

(I'm calling this a backport to 0.2.8, since the fix is obviously safe, and this was a regression)

comment:7 Changed 3 years ago by nickm

Milestone: Tor: 0.2.9.x-finalTor: 0.2.8.x-final
Resolution: fixed
Status: needs_revisionclosed
Note: See TracTickets for help on using tickets.