Opened 3 years ago

Last modified 3 years ago

#19472 needs_information defect

Ongoing downloads icon not working

Reported by: torbacchi Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After updating to 6.0.1, clicking on the "ongoing downloads" icon on the toolbar has no effect, a popup showing downloads is supposed to appear.

Pressing Ctrl+Shift+Y works fine.

(TorBrowser 6.0.1, Linux)

Child Tickets

Change History (8)

comment:1 Changed 3 years ago by gk

Status: newneeds_information

Hm. Works for me on my Linux box. Did that work for you on Tor Browser 5.5.x? Do you get error messages when clicking on it in the browser console (Ctrl + Shift + J)? How did you get the download icon on the toolbar?

comment:2 Changed 3 years ago by torbacchi

Resolution: fixed
Status: needs_informationclosed

Updating to 6.0.2 fixed the issue

comment:3 Changed 3 years ago by torbacchi

Apparently the update was not relevant to the issue. I'm now running 6.0.4 and sometimes the icon stops working.
Last time it stopped working after I opened/closed the downloads popup multiple times in a short time span, by repeatedly clicking on the icon.

comment:4 Changed 3 years ago by gk

Resolution: fixed
Status: closedreopened

Okay, could you provide the information I asked for in comment:1?

comment:5 Changed 3 years ago by gk

Status: reopenedneeds_information

comment:6 Changed 3 years ago by torbacchi

Did that work for you on Tor Browser 5.5.x?

Yes. And it does work on current version too. Only, sometimes it stops working.

Do you get error messages when clicking on it in the browser console (Ctrl + Shift + J)?

No.

How did you get the download icon on the toolbar?

? AFAIK it's always been there

I tried removing it from the toolbar and then re-adding it. But it still won't work.

The only solution I found so far is to restart the browser.

comment:7 Changed 3 years ago by torbacchi

Ok, I can confirm that double-clicking repeatedly on the icon triggers this problem, i.e. the icon stops working.

(Please note that to open the "dowloads popup" usually a single click is needed, not a double click.)

comment:8 Changed 3 years ago by torbacchi

Well, it turns out this is a longstanding bug in Firefox :(

See: https://bugzilla.mozilla.org/show_bug.cgi?id=785054

I can reproduce this in both TorBrowser 6.0.5 (based on Mozilla Firefox 45.4.0) and Firefox 45.3.0, both running on Linux OS, x86 32 bit.

Since mozilla doesn't allow me to create an account on their BTS via Tor, can anyone please add a comment at https://bugzilla.mozilla.org/show_bug.cgi?id=785054 linking this page?

Note: See TracTickets for help on using tickets.