Opened 3 years ago

Closed 2 years ago

#19485 closed enhancement (not a bug)

Use Intel Control-flow Enforcement Technology

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: hardening, cfi, cfe, intel, hardware
Cc: mcs, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Child Tickets

Change History (4)

comment:2 Changed 3 years ago by gk

Cc: gk added

comment:3 Changed 3 years ago by nickm

Milestone: Tor: unspecified

Are there any compiler options for this that we could start experimenting with?

comment:4 Changed 2 years ago by nickm

Resolution: not a bug
Status: newclosed

Once there are compiler options for this, we can use it. But for now, there's no real way to take advantage of it afaik.

Please reopen if/once gcc or clang support exists?

Note: See TracTickets for help on using tickets.