Opened 3 years ago

Closed 3 years ago

#19551 closed defect (fixed)

Edge case test fail in shared random code

Reported by: asn Owned by:
Priority: Medium Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-sr test
Cc: Actual Points:
Parent ID: Points: 0.2
Reviewer: Sponsor:

Description

The test_state_update() test would fail if you run it between 23:30 and
00:00UTC in the following way:

  FAIL src/test/test_shared_random.c:1230: assert(state->n_protocol_runs == 1): 2 vs 1
  [state_update FAILED]
1/1 TESTS FAILED. (0 skipped)

The problem is that when you launch the test at 23:30UTC (reveal phase),
sr_state_update() gets called from sr_state_init() and it will prepare
the state for the voting round at 00:00UTC (commit phase). Since we
transition from reveal to commit phase, this would trigger an unwanted phase
transition and increment the n_protocol_runs counter even before the actual test starts.

The solution is to initialize the n_protocol_runs to 0 explicitly in the
beginning of the test, as we do for n_reveal_rounds, n_commit_rounds etc.

Child Tickets

Change History (4)

comment:1 Changed 3 years ago by asn

Status: newneeds_review

Please find a fix for this in my bug19551 branch. Thanks.

comment:2 Changed 3 years ago by asn

Keywords: tor-prop250 added

comment:3 Changed 3 years ago by dgoulet

Cc: dgoulet removed
Keywords: tor-sr test added; tor-prop250 removed
Status: needs_reviewmerge_ready

ACK!

comment:4 Changed 3 years ago by nickm

Resolution: fixed
Status: merge_readyclosed

merged!

Note: See TracTickets for help on using tickets.