Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#1961 closed defect (worksforme)

Polipo not starting with Vidalia-TOR when in autostart

Reported by: NeoMod Owned by: erinn
Priority: Low Milestone:
Component: Polipo Version: Tor: 0.2.2.12-alpha
Severity: Keywords: polipo autostart failure tbb windows
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Both TOR and Polipo are correctly configured and works well except I must run manually polipo even if Vidalia is on autostart and in the options is configured to launch Polipo after starting Tor.

It could be a OS-related problem? Win7 - x64, admin privileges granted

Child Tickets

Change History (4)

comment:1 Changed 9 years ago by NeoMod

I've also noticed that while running polipo manually it is impossible to pass him the necessary configuration argument to read the Polipo\polipo.conf file instead it will always try to search for etc/resolv.conf file, like under linux.

comment:2 Changed 9 years ago by phobos

Owner: set to erinn
Status: newassigned

We haven't done much testing with Win7 64-bit. If you start polipo without the correct config file, it'll report an error about /etc/resolv.conf. This is because polipo is a kludge on windows at best.

comment:3 Changed 8 years ago by rransom

Resolution: worksforme
Status: assignedclosed

I have never seen this bug on my 64-bit Windows 7 systems. Perhaps we fixed it somehow, or perhaps this was caused by user error.

comment:4 Changed 8 years ago by karsten

Keywords: tbb windows added
Milestone: Tor Browser Bundle for Windows
Note: See TracTickets for help on using tickets.