Opened 3 years ago

Closed 21 months ago

#19620 closed enhancement (implemented)

all metrics-web java projects should use java 8

Reported by: iwakeh Owned by:
Priority: High Milestone: Metrics 2.0.0
Component: Metrics/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #19617 Points:
Reviewer: Sponsor:

Description

use java8 in all java modules.

Child Tickets

Change History (4)

comment:1 Changed 3 years ago by iwakeh

Milestone: Metrics 2.0.0

comment:2 Changed 21 months ago by karsten

Priority: MediumHigh
Status: newneeds_review

Hmmm, looks like some of the changes in #19730 actually required Java 8 which my IDE already uses but which our Ant scripts don't use yet. Can we simply upgrade now? Here's a very short, 1-character-only patch. (Otherwise I'll have to partially revert #19730, and that would be sad.) Raising priority, because master currently doesn't build. Oops.

comment:3 Changed 21 months ago by iwakeh

Status: needs_reviewmerge_ready

Java 8 is very welcome. Merge ready.

comment:4 Changed 21 months ago by karsten

Resolution: implemented
Status: merge_readyclosed

Merged. Thanks for the quick review! Closing.

Note: See TracTickets for help on using tickets.