Opened 3 years ago

Closed 3 years ago

#19721 closed defect (duplicate)

Circuit on detached list which I had no reason to mark

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Running a relay on Debian 8 amd64.
0.2.7.6-1~d80.jessie+1

While investigating why my relay had basically no network traffic (<MBit/s) for several hours, I stumbled onto this log line:

circuit_unlink_all_from_channel(): Bug: Circuit on detached list which I had no reason to mark (on Tor 0.2.7.6 )

Network traffic was down (most likely NOT due to infrastructure/upstream issues), at the end of that period the log entry appeared and network traffic got back to normal.

Since I'm not sure whether this is a duplicate of
https://trac.torproject.org/projects/tor/ticket/12184
I'm reporting it separately and leave it for others to flag it as duplicate if that seems to be the case.

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by nickm

Resolution: duplicate
Status: newclosed

Thanks for reporting; I do believe that's a duplicate of #12184

Note: See TracTickets for help on using tickets.