Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19725 closed defect (fixed)

old updater files are left on disk after upgrade to TB 6.x

Reported by: mcs Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-6.0-issues, TorBrowserTeam201607R
Cc: brade, sukhbir, arthuredelstein, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Some blog comments indicate that old mar files are being left on disk after a successful update from Tor Browser 5.x to 6.x. Kathy and I have confirmed that this is indeed happening on Windows and Linux.

During the #13252 work, we moved the update info directory to a (more) consistent place on all platforms but we did not account for the issue of upgrading from older releases. The new location for update info is Browser/UpdateInfo on Linux and Windows and TorBrowser-Data/UpdateInfo on OSX.

On Windows, the old location (where files are left on disk and not cleaned up) is <installdir>/Browser/TorBrowser/Data/Browser/caches/firefox.

On Linux, the old location is `<installdir>/Browser (an updates/ directory plus old active-update.xml and updates.xml files are left there).

Another consequence of this bug is that update history information is lost during the 5.x to 6.x update (because the code in TB 6.x does not look in the old place for it after the update is applied).

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by mcs

At this point, the best solution is probably to remove the orphaned files after the next successful update. We can add some code to _postUpdateProcessing() inside toolkit/mozapps/update/nsUpdateService.js to take care of deleting the files.

comment:2 Changed 3 years ago by arthuredelstein

Cc: arthuredelstein added

comment:3 Changed 3 years ago by mcs

Cc: mikeperry added
Keywords: TorBrowserTeam201607R added
Status: newneeds_review

Kathy and I have prepared a patch:
https://gitweb.torproject.org/user/brade/tor-browser.git/commit/?h=bug19725-01&id=3e71b6bae8d14081c24785d43ef5190a55b0da02

Please review. I think this is a fairly safe patch, but will leave it to Mike to decide whether to take it for the upcoming stable and alpha releases. This is not an urgent issue, although leaving large mar files on disk is an annoying thing for us to do.

comment:4 Changed 3 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Taking this for 6.5a2 (commit e0f6ebcc0f63602d59bb1b954029d1950a3e58a5 on tor-browser-45.3.0esr-6.5-1). I guess we'll backport it for the next stable after it got some testing in our alphas.

comment:5 Changed 3 years ago by gk

Backported to tor-browser-45.4.0esr-6.0-1 with commit 11de35257e2b4ce656f71c0d5f08c339ab7f172d.

Note: See TracTickets for help on using tickets.