Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1973 closed defect (duplicate)

Warning from libevent, then Tor doesn't work

Reported by: Sebastian Owned by:
Priority: Low Milestone: Tor: 0.2.2.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This looks like it might be related to #792 (or be in fact the same bug), but 792 is supposed to be fixed in libevent 1.4.12.

The log as displayed by Vidalia is this:

Sep 25 01:18:35.311 [Notice] Tor v0.2.2.15-alpha (git-eba3f37f17a2af4f). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows XP Service Pack 2 [workstation])
Sep 25 01:18:36.405 [Warning] Warning from libevent: evsignal_init: socketpair: No error
Sep 25 01:18:36.405 [Notice] Initialized libevent version 1.4.14-stable using method win32. Good.
Sep 25 01:18:36.405 [Notice] Opening Socks listener on 127.0.0.1:9050
Sep 25 01:18:36.405 [Notice] Opening Control listener on 127.0.0.1:9051
Sep 25 01:18:36.405 [Notice] Parsing GEOIP file.
Sep 25 01:18:46.402 [Notice] OpenSSL OpenSSL 0.9.8k 25 Mar 2009 [9080bf] looks like it's older than 0.9.8l, but some vendors have backported 0.9.8l's renegotiation code to earlier versions, and some have backported the code from 0.9.8m or 0.9.8n.  I'll set both SSL3_FLAGS and SSL_OP just to be safe.
Sep 25 01:18:47.056 [Notice] We now have enough directory information to build circuits.
Sep 25 01:18:47.056 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Sep 25 01:18:48.152 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Sep 25 01:18:48.805 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Sep 25 01:18:51.599 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Sep 25 01:18:51.599 [Notice] Bootstrapped 100%: Done.

No Windows or other firewall running according to the user. It looks like Vidalia loses connection to the Tor in the process, too.

This could be a bug with the way we built the bundle, though I just tried it on win7 and it worked fine, or a libevent bug, or a Tor bug; or all of the above. Ideas?

Child Tickets

Change History (4)

comment:1 Changed 9 years ago by arma

Milestone: Tor: 0.2.2.x-final
Priority: normalminor

Moving to 0.2.2.x milestone, but with priority minor since it can slip if we never learn anything more about it.

comment:2 Changed 9 years ago by nickm

The socketpair thing looks just like #792; if we don't find any more info here, I'm going to say there's a firewall or AV thing here anyway, and the right thing to do is look harder at that assumption.

comment:3 Changed 9 years ago by nickm

Resolution: duplicate
Status: newclosed

Duplicate of #1812.

comment:4 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.