#19732 closed defect (invalid)

"Tor circuit for this site" labels meek bridge as being in China

Reported by: dcf Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: meek
Cc: mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser 6.5a1

I configured meek-azure in Torbutton. The circuit display shows "China" for the country of the bridge.

IIRC it used to say "Unknown". Maybe there is a geoip lookup error for the 0.0.2.0 dummy bridge address.

Child Tickets

Attachments (1)

meek-azure-geoip-china.png (20.7 KB) - added by dcf 10 months ago.

Download all attachments as: .zip

Change History (5)

Changed 10 months ago by dcf

comment:1 Changed 10 months ago by dcf

  • Keywords meek added

comment:2 Changed 10 months ago by gk

Hm, interesting. For me it is just saying Bridge: meek both if I configure it by clicking on the green onion and during start-up with a vanilla 6.5a1. This is on a Linux system (64bit en-US).

comment:3 Changed 10 months ago by mcs

  • Cc mcs added

Another data point: I was unable to reproduce this on an OSX 10.11.5 system with TB 6.5a1. But dcf's screenshot does not lie, so there must be something different about his setup.

comment:4 Changed 10 months ago by dcf

  • Resolution set to invalid
  • Status changed from new to closed

This was my fault. It turns out I had somewhere in the past been hacking on my files to test something, and changed the dummy address for meek-azure to 1.2.2.4.

Note: See TracTickets for help on using tickets.