Opened 4 years ago

Closed 3 years ago

#19739 closed defect (fixed)

Bad family members

Reported by: hsys Owned by: irl
Priority: Low Milestone:
Component: Metrics/Relay Search Version:
Severity: Minor Keywords: atlas; familymembers
Cc: starlight@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When you search any Nodes from the details page of another Node, family members field on the new node searched is not updated (are those of the previous node).

Child Tickets

Attachments (3)

01-glittershy.jpg (167.6 KB) - added by karsten 3 years ago.
02-Binnacle-before-reset.jpg (143.3 KB) - added by karsten 3 years ago.
03-Binnacle-after-reset.jpg (138.8 KB) - added by karsten 3 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 3 years ago by starlight

Cc: starlight@… added

comment:2 Changed 3 years ago by karsten

Status: newneeds_information

I'm afraid I don't understand this bug. When I'm on a details page of a relay that has one or more family members and I click on one of them, a new details page opens with updated family members. Of course, most family members will be the same, because the two relays are part of the same family. But at least the currently displayed relay is not listed under its family members, so there's a change.

I'll set this ticket to needs_information for now with the intention of closing it if we cannot track this down in the near future. If this bug really exists, please consider attaching screenshots or providing fingerprints of affected relays. Thanks!

comment:3 Changed 3 years ago by starlight

Simple to reproduce:

navigate to

https://atlas.torproject.org/#details/2936A5394D2DA14BF473545AEC7675C0C87B859E

notice family members

then navigate to

https://atlas.torproject.org/#details/4F0DB7E687FC7C0AE55C8F243DA8B0EB27FBF1F2

notice family members -- list is same

then reset your browser and try the latter again

notice no family members

comment:4 Changed 3 years ago by cypherpunks

Unable to reproduce this.

https://atlas.torproject.org/#details/2936A5394D2DA14BF473545AEC7675C0C87B859E
shows one family member: $664420DB8393F474E948A4415FDFEF03DE1505D2

https://atlas.torproject.org/#details/4F0DB7E687FC7C0AE55C8F243DA8B0EB27FBF1F2
shows no family member;

What do you mean by "reset your browser" does a restart of torbrowser "reset" the browser.

comment:5 Changed 3 years ago by starlight

Perhaps this is somewhat specific.

1) yes, restart == reset

2) Linux 64-bit 6.0.8 TB

3) security slider at medium

4) NoScript blocking everything by default, but Atlas permitted in whitelist

comment:6 Changed 3 years ago by starlight

be sure to paste the provided URLs into the same browser window+tile location bar successively

Changed 3 years ago by karsten

Attachment: 01-glittershy.jpg added

Changed 3 years ago by karsten

Changed 3 years ago by karsten

Attachment: 03-Binnacle-after-reset.jpg added

comment:7 Changed 3 years ago by karsten

Status: needs_informationnew

Ah, I can reproduce that bug now. Here are some screenshots:




Here are the current details documents for the two relays (note that the second document doesn't have an "effective_family" field, unlike the first):

{"version":"3.1",
"relays_published":"2017-01-10 10:00:00",
"relays":[
{"nickname":"glittershy","fingerprint":"2936A5394D2DA14BF473545AEC7675C0C87B859E","or_addresses":["173.79.162.220:9001","[2001:470:8:79b:1::beef]:9001"],"dir_address":"173.79.162.220:9030","last_seen":"2017-01-10 10:00:00","last_changed_address_or_port":"2016-10-21 15:00:00","first_seen":"2015-10-22 04:00:00","running":true,"flags":["Exit","Fast","HSDir","Running","Stable","V2Dir","Valid"],"country":"us","country_name":"United States","region_name":"Virginia","city_name":"Centreville","latitude":38.8159,"longitude":-77.4607,"as_number":"AS701","as_name":"MCI Communications Services, Inc. d/b/a Verizon Business","consensus_weight":8080,"host_name":"pool-173-79-162-220.washdc.fios.verizon.net","last_restarted":"2017-01-06 08:07:34","bandwidth_rate":6144000,"bandwidth_burst":8192000,"observed_bandwidth":8233846,"advertised_bandwidth":6144000,"exit_policy":["reject 0.0.0.0/8:*","reject 169.254.0.0/16:*","reject 127.0.0.0/8:*","reject 192.168.0.0/16:*","reject 10.0.0.0/8:*","reject 172.16.0.0/12:*","reject 173.79.162.220:*","reject 64.27.17.141:*","reject *:25","reject *:119","reject *:135-139","reject *:445","reject *:563","reject *:1214","reject *:4661-4666","reject *:6346-6429","reject *:6699","reject *:6881-6999","accept *:*"],"exit_policy_summary":{"reject":["25","119","135-139","445","563","1214","4661-4666","6346-6429","6699","6881-6999"]},"contact":"TOR Administrator <tor AT glittershy dot net>","platform":"Tor 0.2.8.12 on Linux","effective_family":["$664420DB8393F474E948A4415FDFEF03DE1505D2"],"consensus_weight_fraction":1.67156E-4,"guard_probability":0.0,"middle_probability":0.0,"exit_probability":7.313596E-4,"recommended_version":true,"measured":true}
],
"bridges_published":"2017-01-10 08:41:04",
"bridges":[
]}
{"version":"3.1",
"relays_published":"2017-01-10 10:00:00",
"relays":[
{"nickname":"Binnacle","fingerprint":"4F0DB7E687FC7C0AE55C8F243DA8B0EB27FBF1F2","or_addresses":["108.53.208.157:443"],"dir_address":"108.53.208.157:80","last_seen":"2017-01-10 10:00:00","last_changed_address_or_port":"2015-06-12 18:00:00","first_seen":"2014-06-14 20:00:00","running":true,"flags":["Fast","Guard","HSDir","Running","Stable","V2Dir","Valid"],"country":"us","country_name":"United States","region_name":"New York","city_name":"New York","latitude":40.7391,"longitude":-73.9826,"as_number":"AS701","as_name":"MCI Communications Services, Inc. d/b/a Verizon Business","consensus_weight":8350,"host_name":"static-108-53-208-157.nwrknj.fios.verizon.net","last_restarted":"2016-11-24 18:57:39","bandwidth_rate":1073741824,"bandwidth_burst":1073741824,"observed_bandwidth":8719971,"advertised_bandwidth":8719971,"exit_policy":["reject *:*"],"exit_policy_summary":{"reject":["1-65535"]},"contact":"starlight dot YYYYqQ at binnacle dot cx","platform":"Tor 0.2.6.10 on Linux","consensus_weight_fraction":1.7274165E-4,"guard_probability":2.6893202E-4,"middle_probability":1.788938E-4,"exit_probability":0.0,"recommended_version":false,"measured":true}
],
"bridges_published":"2017-01-10 08:41:04",
"bridges":[
]}

This is something that a real JavaScript developer should look at.

comment:8 Changed 3 years ago by RaBe

Owner: changed from irl to RaBe
Status: newassigned

comment:9 Changed 3 years ago by RaBe

Owner: changed from RaBe to irl

Family members weren't reset if neither effective nor alleged members existed. Here's the fix:

https://github.com/RaphaelBergmann/atlas/commit/7dd7005ae3bdb9cff5eade61760af58496c050d7

comment:10 Changed 3 years ago by RaBe

Status: assignedneeds_review

comment:11 Changed 3 years ago by cypherpunks

The empty_family variable seems to be unused (a grep turned up nothing) meaning that if/else block can be removed entirely.

comment:12 Changed 3 years ago by irl

Status: needs_reviewneeds_revision

RaBe: if cypherpunks is right (seems to be) then can you update the patch to remove that if/else block?

comment:14 Changed 3 years ago by irl

Resolution: fixed
Status: needs_reviewclosed

Merged. Thanks. (:

Note: See TracTickets for help on using tickets.