Opened 3 years ago

Closed 3 years ago

#19810 closed enhancement (duplicate)

Could high-bandwidth ORPort-only relays be fallbacks?

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: fallback
Cc: Actual Points:
Parent ID: Points: 2
Reviewer: Sponsor:

Description

In 0.2.8, relays automatically support begindir over ORPort, even if they don't have a DirPort.

I wonder if we're missing out on (m)any high-bandwidth relays by excluding relays without a DirPort. That said, we wouldn't want too many, because relays still use the DirPort to bootstrap off fallbacks. (But if the fallback only has an ORPort, the relay will use that.)

We'd need to make the following changes for this to happen:

  • modify the DirPort requirement during fallback selection to check for either a DirPort, or declared begindir support in the descriptor
  • make a DirPort optional for configured FallbackDirs in Tor
    • this may be as simple as setting the DirPort to 0, and disabling the validation. The rest of the code might just work, because it ignores 0 DirPorts
  • test, test, test

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by teor

Resolution: duplicate
Status: newclosed

Duplicate of #19129

Note: See TracTickets for help on using tickets.