Opened 3 years ago

Closed 7 weeks ago

#19839 closed defect (fixed)

BridgeDB website: In firefox page shows titles in English and text in the language preferred by the user

Reported by: sebalis Owned by: traumschule
Priority: Low Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Normal Keywords: bridgedb-reportbug, anti-censorship-roadmap-september, s30-o22a3
Cc: irl Actual Points: 0.1
Parent ID: #31279 Points:
Reviewer: Sponsor: Sponsor30-must

Description

Browsing to https://bridges.torproject.org/ from Germany using an English Firefox, I am served a page that shows headlines in English, but the rest (as far as I checked) is in German. The German text is not bad but should be improved in some places as it seems too close to the English original with some incorrect translation choices. As a native speaker and also long-standing translator/interpreter for Digitalcourage and the CCC I’d be happy to help. (And since this ticket will apparently be “owned” by Isis, I’d like to add that I’m hugely looking forward to being her interpreter for her upcoming talk at Digitalcourage’s “Public Domain” event. ☺)

Child Tickets

Change History (17)

comment:1 Changed 3 years ago by sebalis

During some further investigation for reporting bug #19841 I found that the headlines have been translated to German too, but these translations were not served to me. Using the Tor Browser I either get a fully English or fully German page depending on my language choices. Anyway, I can submit suggestions for some (very small) language changes using any channel you prefer. However I will not be online a lot until 19 Aug.

comment:2 in reply to:  description ; Changed 3 years ago by isis

Component: User Experience/WebsiteObfuscation/BridgeDB

Replying to sebalis:

Browsing to https://bridges.torproject.org/ from Germany using an English Firefox, I am served a page that shows headlines in English, but the rest (as far as I checked) is in German. The German text is not bad but should be improved in some places as it seems too close to the English original with some incorrect translation choices. As a native speaker and also long-standing translator/interpreter for Digitalcourage and the CCC I’d be happy to help.


Hi! That's odd that the headlines were in English. Do you mean the text in <h1></h1> (etc.) tags, or also the text in the titlebar/menubar of Firefox? As you mentioned, using Tor Browser, I also get all German or all English, depending on my language settings.

As for improving the German, we use Transifex, and I'm happy to figure out how to get you an account there. I'm also happy to take suggestions here and put them into Transifex for you. (Und ja auch kann ich irgenwie deutsch sprechen… zumeist. Die aktuelle Übersetzung ist vielleicht ein bisschen schade, aber auch ist sie nicht meine Muttersprache. :)

(And since this ticket will apparently be “owned” by Isis, I’d like to add that I’m hugely looking forward to being her interpreter for her upcoming talk at Digitalcourage’s “Public Domain” event. ☺)


Voll knorke!

comment:3 in reply to:  2 Changed 3 years ago by sebalis

Replying to isis:

Hi! That's odd that the headlines were in English. Do you mean the text in <h1></h1> (etc.) tags, or also the text in the titlebar/menubar of Firefox? As you mentioned, using Tor Browser, I also get all German or all English, depending on my language settings.

I mean the text in <h4> tags on https://bridges.torproject.org/, https://bridges.torproject.org/options and https://bridges.torproject.org/howto – I’ve seen one h3 tag with German content, no h2 or h1.

It does seem to depend on my language preferences in Firefox. Using a fresh profile (and as I said, my Firefox itself is en-US and the OS is English too) and its default language preferences, which are to 1. en-US, 2. en, I get all English content. Changing to 1. en, 2. de as mentioned before gives me what I’m describing here: h4 content is English, body text German.

As for improving the German, we use Transifex, and I'm happy to figure out how to get you an account there. I'm also happy to take suggestions here and put them into Transifex for you. (Und ja auch kann ich irgenwie deutsch sprechen… zumeist. Die aktuelle Übersetzung ist vielleicht ein bisschen schade, aber auch ist sie nicht meine Muttersprache. :)

Massive respect for the effort! The text is very good already, looking closer I think I would have very little to suggest. I’d regard Bug #19841 as more important, adding a switcher and solving the mixed content puzzle. But if you get me an account on Transifex I will devote some time to the German content as well. (At the moment surfing to the Transifex link gives me a 403 page.)

comment:4 Changed 16 months ago by traumschule

Component: Obfuscation/BridgeDBCommunity/Translations

comment:5 Changed 15 months ago by traumschule

Owner: changed from isis to traumschule
Status: newassigned

ja ok, was able to reproduce it. will review the translation. contributions welcome!
transifex / git

comment:6 Changed 14 months ago by traumschule

Status: assignedneeds_information

Added some alternative suggestions in transifex, apart from that the translation does not look too bad. If you name some concrete examples i can add them for you.

comment:7 Changed 13 months ago by emmapeel

Component: Community/TranslationsObfuscation/BridgeDB

i move it to the bridgesdb component because it is a matter of code, not of the translations per se, or at least i dont see the problem with the translations.

comment:8 Changed 13 months ago by emmapeel

Cc: sysrqb added
Summary: BridgeDB website: German translation could be improved (and completed)BridgeDB website: In firefox page shows titles in English and text in the language preferred by the user

I confirm that the same happens when loading BridgesDB in a Firefox with Spanish as main language>

The titles of the first page are shown in English. but the texts in Spanish.

I have edited the title of the ticket accordingly.

comment:9 Changed 11 months ago by gaba

Sponsor: Sponsor19

comment:10 Changed 6 months ago by phw

Sponsor: Sponsor19Sponsor30-must

Moving from Sponsor 19 to Sponsor 30.

comment:11 Changed 5 months ago by gaba

Cc: irl added; isis sysrqb removed
Keywords: anti-censorship-roadmap-september added

comment:12 Changed 4 months ago by phw

Parent ID: #31268

comment:13 Changed 4 months ago by phw

Parent ID: #31268#31279

comment:14 Changed 3 months ago by gaba

Keywords: s30-o22a3 added

comment:15 Changed 2 months ago by phw

I may have run into the same (or a similar) problem while implementing #26543. Here's how I could reproduce the issue:

  • Set your "preferred language for displaying pages" in Firefox to, say, German.
  • Go to bridges.torproject.org and override the German translation by adding ?lang=en to the URL.
  • Parts of the page will still use the German translation even though English translations are available.

I believe I fixed the issue in commit 28a7e80. Apparently the fuzzy tag prevents BridgeDB's Babel library from re-compiling languages that are marked as fuzzy. This can result in translations not being used even though they are available.

emmapeel, do you still see the same issue?

comment:16 Changed 7 weeks ago by emmapeel

I see the sentences:

Another way to get bridges is to send an email to bridges@…. Please note that you must send the email using an address from one of the following email providers: Riseup or Gmail.

And

If your Tor Browser cannot connect, please take a look at the Tor Browser Manual and our Support Portal.

In the browser locale, independently of the ?lang=it or ?lang=es on the URL. They are translated on the translation platform tho.

comment:17 in reply to:  16 Changed 7 weeks ago by phw

Actual Points: 0.1
Resolution: fixed
Status: needs_informationclosed

Replying to emmapeel:

I see the sentences:

Another way to get bridges is to send an email to bridges@…. Please note that you must send the email using an address from one of the following email providers: Riseup or Gmail.

And

If your Tor Browser cannot connect, please take a look at the Tor Browser Manual and our Support Portal.

In the browser locale, independently of the ?lang=it or ?lang=es on the URL. They are translated on the translation platform tho.


That's expected because BridgeDB currently doesn't use up-to-date translations. But given that the title strings are properly translated, it looks like we already fixed this bug in #26543.

Note: See TracTickets for help on using tickets.