Opened 3 years ago

Closed 12 months ago

#19841 closed defect (duplicate)

BridgeDB website: surprising choices and no language switcher

Reported by: sebalis Owned by:
Priority: Medium Milestone:
Component: Webpages/Webtools Version:
Severity: Normal Keywords: bridgedb-reportbug, website-content
Cc: isis Actual Points:
Parent ID: Points:
Reviewer: hiro Sponsor:

Description

Browsing to https://bridges.torproject.org/ from Germany using an English Firefox, I am served a page that shows headlines in English, but the rest (as far as I checked) is in German. This language choice is surprising to me as I think the browser’s language as transmitted in the HTTP headers should be the main factor. Strangely, using the Tor Browser and declining the question whether I want to request English content for improved anonymity, I get a page that is fully German despite my exit node being in the UK, so geolocating can not be the sole criterion for this language choice either. This might become a problem because the website does not seem to offer a means for switching the language.

Child Tickets

Change History (10)

comment:1 Changed 3 years ago by sebalis

Given that using the Tor Browser I see content that is either fully English or fully German, it really seems very surprising that I should see mixed content when using my regular Firefox profile. The language preferences I have set in that profile are English (en) first, German (de) second.

comment:2 Changed 2 years ago by hiro

Keywords: website-content added

comment:3 Changed 15 months ago by traumschule

Component: Webpages/WebsiteWebpages/Webtools
Reviewer: hiro
Status: newneeds_information

Are you still able to it reproduce it? I was not. Maybe it's it's fixed?

comment:4 Changed 15 months ago by sebalis

It seems to depend on the fine details of my language settings. If I use 1. en-GB, 2. de-DE, then I get a page that’s English only. Reversing the order gives me a fully German page. The behaviour I describe still occurs for my original settings, which are 1. en, 2. de (note the absence of a region). I skipped the comparison with the Tor Browser since geolocation does not seem the decisive factor here. (To clarify, what I meant with “headlines” in my original report are the questions, which are H4 elements.)

Last edited 15 months ago by sebalis (previous) (diff)

comment:5 Changed 15 months ago by emmapeel

I would like to have a language switcher too, it is a good practice not to follow only the browser preferences, but leave the user the freedom of choice in case the browser is configured to another language.

comment:6 Changed 13 months ago by traumschule

Owner: changed from isis to traumschule
Status: needs_informationassigned

Now i am able to reproduce it, thanks for the clarification. So far i only risked a short view but i assume the answer to this mystery lies somewhere in https://gitweb.torproject.org/bridgedb.git/tree/bridgedb/strings.py
Maybe with emma's help i am able to solve it.

Last edited 13 months ago by traumschule (previous) (diff)

comment:7 Changed 13 months ago by traumschule

This is the same for french and probably other languages. See also comment:3:ticket:19839

The question is why text in <p> tags is served localized while <h4> isn't.

So far i'm collecting relevant parts:

comment:8 Changed 12 months ago by traumschule

Owner: traumschule deleted

No idea.

comment:9 Changed 12 months ago by emmapeel

One thing I see is that the translations are very old in the BridgesDB directory: the German translations is from 2015. So if there were more translations in po file: ​https://gitweb.torproject.org/translation.git/tree/de/LC_MESSAGES/bridgedb.po?h=bridgedb_completed they need to be added to https://gitweb.torproject.org/bridgedb.git/ and maybe some of the strings get translated.

The BridgesDB webpage goes with the AcceptHeaders of the browser it seems, and the default is English (en).

If you have de, for the browser is unfortunately not de-DE. Is silly, I know. That is why you have to add de and de-DE to your browser.

(But yeah, the accept language headers give some information about you and make you different from the other users, and maybe you want to show the page to a friend that speaks another language, etc)

Last edited 12 months ago by emmapeel (previous) (diff)

comment:10 Changed 12 months ago by emmapeel

Resolution: duplicate
Status: assignedclosed

this ticket duplicates #19839 from my POV...

Note: See TracTickets for help on using tickets.